8.х Срок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 19 май 2015.

  1. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    Нужно получить срок перевозчика из пункта до пункта,
    Сделал но получил только с одного пункта как правильно сделать?? где я ошибся?
    Спасибо!
    Код:
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
        Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400
    //    Объект.Срок = Объект.ДатаЗаезда - Объект.ДатаВыезда;
    //    Секунды = Объект.ДатаЗаезда - Объект.ДатаВыезда;
    //Дни = Секунды/ 60 / 60 / 24;
    //Секунды= Секунды- Цел(Дни) * 24 * 60 * 60; //получили остаток секунд
    //Часы = Секунды/ 60 / 60;
    //Секунды= Секунды- Цел(Дни) * 60 * 60;//получили остаток секунд
    //Минуты = Секунды / 60;
    //Секунды = Секунды - Цел(Минуты) * 60;//получили остаток секунд
    //Сообщить(Строка(Дни) + "день"+(дней) + Строка(Часы) + "часов" + Строка(Минуты) + "минут" + Строка(Секунды) + "Секунд"));
    
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
        Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400
        //Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400
    
    КонецПроцедуры
    
    upload_2015-5-19_17-37-32.png
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    Разница дат дает разницу в секундах. Что мешает корректно преобразовать секунды в нужное вам количество времени ?
  3. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    А конкретнее в Днях в часах или как?
    и по каким полям ДатаВыезда и ДатаЗаезда?
    Может проще запросом через РазностьДАТ() а там уже укажите ДНи часы или секунды
    --- Объединение сообщений, 19 май 2015 ---
    РАЗНОСТЬДАТ(&дата1,&Дата,ДЕНЬ)
    РАЗНОСТЬДАТ(&дата1,&Дата,Час)
    РАЗНОСТЬДАТ(&дата1,&Дата,Месяц)
  4. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    нужен РАЗНОСТЬДАТ(&дата1,&Дата,ДЕНЬ) и он работает только на первом пункте тоже самое нужно на втором пункте
    --- Объединение сообщений, 19 май 2015 ---
    upload_2015-5-19_17-46-44.png
    --- Объединение сообщений, 19 май 2015 ---
    upload_2015-5-19_17-55-13.png

    upload_2015-5-19_17-55-44.png
    Последнее редактирование: 19 май 2015
  5. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    подскажите пожалуйста как правильно решить???
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    ЧТО РЕШИТЬ ??????????????????????????????????????
    Вам уже два варианта предложили. За вас код написать чтоль ???????????
  7. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    А что в Объект.ДатаЗаездаПункт2 и Объект.ДатаВыездаПункт2

    какая из них пустая или как что в отладчике на этой строке в них когда 0
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    сообщения, не имеющие отношения к теме - удаляю. Эльдар, вы же знаете что я за вами наблюдаю :)
  9. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    оба заполнены
    --- Объединение сообщений, 19 май 2015 ---
    да знаю!-Arghh-
    ну посмотрите один код работает а на другом не но тоже самое
  10. XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    покажите скриншот со значениями и значение Срок2 - на вашем скриншоте это значение ещё не посчитано.
  11. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    НУ можно табло в котром 3 эти параметра Срок 2 и эти даты на этой точке остановки
    илил как вариант закройте все откройте конфигуратор, еще раз изимените код, пересохраните, обновите конфигурацию и только потом запустите отладчик
  12. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Эмиль0690 у вас фигня какая-то в событиях.
    Сейчас 1 сек.
  13. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
  14. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Как-то так это надо сделать:
    Код:
    
    &НаКлиенте
    Процедура ОбновитьСроки()
      Объект.Срок = (НачалоДня(Объект.ДатаЗаезда) - НачалоДня(Объект.ДатаВыезда)) / 86400;
      Объект.Срок2 = (НачалоДня(Объект.ДатаЗаездаПункт2) - НачалоДня(Объект.ДатаВыездаПункт2)) / 86400;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПриИзменении(Элемент)
      ОбновитьСроки();
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДатаВыездаПункт2ПриИзменении(Элемент)
      ОбновитьСроки();
    КонецПроцедуры
    
    
  15. XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    после вычисления чему Объект.Срок2 равен?
  16. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    А хотя не. Особого значения не имеет. У вас же исходные разные поля.
  17. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    да в табло выведите 3 параметра
  18. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    этот код не работает(
    можете объяснить почему пункт2 неработая а пункт1 работает код один и тоже???
  19. XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Эмиль, вы адекватный человек?

    Вам уже несколько раз написали - выложите скриншот отладчика, на котором будет видно, чему равны все три параметра!!!

    Кроме того - на форме у вас какой параметр выведен?
  20. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    да я думаю что я адекватный хотя со стороны лучше виднее, alexburn знает какой я человек
    все скриншоты не работают тоже самое что старый код
    что вы имеете ввиду "Кроме того - на форме у вас какой параметр выведен?" какой параметр?

Поделиться этой страницей