7.7 Средняя цена

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Cooper-Mixal, 14 окт 2008.

  1. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день!!!

    Появилась такая проблемма,
    Участки делают выгрузку из своей базы и загрузку в бухгалтерию документов.
    Сейчас в базе средняя цена формируется по всем участкам, а надо чтобы средняя цена формировалась по каждому участку своя средняя цена!

    Даже не представляю, где идет формирование средней цены в буховской базе!

    Что посоветуете?

    Кто сталкивался с подобной проблеммой?
  2. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Нашел такой пост, что скажете????

    Доработать конфу Бух 7.7 под суммовой учет по местам хранения очень просто, я такое делал для многих организаций.
    Но начнем с теории - почему сама 1С это не реализовала, если это так легко? Все дело в инструкциях по бухучету. В них черным по белому сказано, что организация обязана вести количественный учет в разрезе МОЛ (в нашем случае, мест хранения), а в суммовой учет - В ЦЕЛОМ по организации. Вот поэтому, в плане счетов для 10, 41 и 43, для субконто МестаХранения убран галка "Учет по сумме", а в документах списания ТМЦ средняя цена списания определяется не по складу, а в целом по всему счету.

    Следовательно, чтобы реализовать сабж, нужно сделать всего-то ничего:
    1) В плане счетов для счетов 10.1,10.2,10.3,10.4,10.5,10.6,10.8,10.9,10.10, 21, 41.1,41.3,41.4 и 43 убрать галку "Учет по сумме"
    2) В модуле проведения документов "РасходнаяНакладная", "ОтпускМатериаловНаСторону", "ТребованиеНакладная", "ПеремещениеТоваров" строки:
    // БухИт/БИ10/БИ21и43.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
    заменить на:
    БухИт/БИ10/БИ21и43.ИспользоватьСубконто(ВидыСубконто.МестаХранения,МестоХранения, 2); // будет вместо остатков на складах выводить остатки по выбр. местуХранения (МОЛ)

    2) В модуле проведения документов "ТребованиеНакладная" внести следующие изменения (добавленные/исправленные мною строки помечены словом МОЕ)
    ....
    //МОЕ Если ВидПеремещения = 0 Тогда
    Стр = ""+ТаблицаОстатков.НомерСтроки+". "+ТаблицаОстатков.Материал+": на складе "+МестоХранения+" "+КоличествоНаСкладе+" "+
    ТаблицаОстатков.Материал.ЕдиницаИзмерения+", всего на складах "+ТаблицаОстатков.КоличествоНаСкладах+" "+
    ТаблицаОстатков.Материал.ЕдиницаИзмерения+" на сумму "+ТаблицаОстатков.СуммаНаСкладах;

    Если ТаблицаОстатков.КоличествоНаСкладах > 0 Тогда
    Стр = Стр + ", средняя стоимость " + Окр(ТаблицаОстатков.СредняяСтоимость, 2, 1);
    КонецЕсли;
    ТекстСообщения = Стр;
    глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
    //МОЕ КонецЕсли;

    ...
    ; Если КоличествоОтпущено >= ТаблицаОстатков.КоличествоНаСкладах Тогда
    ; СуммаОтгрузки = ТаблицаОстатков.СуммаНаСкладах;

    ; Иначе
    ; СуммаОтгрузки = Окр(КоличествоОтпущено*ТаблицаОстатков.СредняяСтоимость, 2, 1);
    ; КонецЕсли;

    ; // Уменьшим остаток материала на списанное количество.
    ; ТаблицаОстатков.СуммаНаСкладах = ТаблицаОстатков.СуммаНаСкладах - СуммаОтгрузки;
    ; ТаблицаОстатков.КоличествоНаСкладах = ТаблицаОстатков.КоличествоНаСкладах - КоличествоОтпущено;
    Если ВидПеремещения = 0 Тогда // передача в производство
    // МОЕ строки (помеченные ";"), которые стояли на месте этого ком-я, переставлены перед <Если ВидПеремещения = 0 Тогда>

    Операция.НоваяПроводка();
    ...

    ...
    Операция.Количество = КоличествоОтпущено;
    Операция.Сумма = СуммаОтгрузки; //МОЕ
    Операция.СуммаОперации = Операция.СуммаОперации + Операция.Сумма; //МОЕ

    // В скрытой колонке табличной части очистим cумму.
    Сумма = Операция.Сумма; //МОЕ
    ...

    4) перепровести эти документы за весь период, чтобы они верно отразили суммы по счетам (с учетом новой логики)
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    И что тут сказать? хотите отступать от интрукций? тогда надо дорабатывать (обычно стоит немного дороже "правильных" доработок)
  4. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Как правильно доработать? Подскажи!
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    я навряд ли могу подсказать, российскую настройку плохо знаю (я по Белоруси специализируюсь)

Поделиться этой страницей