8.х Средняя цена

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Реалистка, 17 ноя 2011.

  1. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Всем здрасьте!
    У Меня проблема.
    Есть 3 документа - Приход, расход, остатки.
    В документе расход, в реквизите ТЧ "Цена" необходимо, чтобы расчет данных происходил по следующей форме, когда забиваешь сумму и количество = (Сумма нач. мес. + СуммаПриход)/ (Количество нач. мес + КоличествоПриход). Как это реализовать??????? ПОМОГИТЕ....
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Сделайте по аналогии...

    Код:
    Процедура ТабличнаяЧасть1КоличествоПриИзменении(Элемент)
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    ПриходТабличнаяЧасть.Сумма,
    |    ПриходТабличнаяЧасть.Количество
    |ИЗ
    |    Документ.Приход.ТабличнаяЧасть КАК Приход";
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
    СуммаПриход = Выборка.Сумма;
    КоличествоПриход = Выборка.Количество;
    КонецЦикла;
    Если ЗначениеЗаполнено(Сумма) И ЗначениеЗаполнено(Количество) Тогда
    ОбщаяСумма = (СуммаНачМес + СуммаПриход) / (КоличествоНачМес + КоличествоПриход);
    КонецЕсли;
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Спасибочки огромное!!!
    Сейчас попробую...
  4. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Не выходит. кругом и везде ошибок море
  5. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Что за ошибки? Какие действия выполняете? Опиши все подробно...
  6. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Открываю форму документа расход, далее процедуру количество при изменении, вставляю данный код, ошибки появляются плана, что он не видит сумму на начало месяца и количество на начало месяца.
  7. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Я так предполагаю, что это реквизиты документа приход? Если так, то их тоже надо добавить в запрос.
    Может конфигурацию вашу скинете, я посмотрю, как время будет...
  8. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Буду очень благодарна
  9. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Ну вы конфигурацию то скиньте...Меню конфигурация - выгрузить конфигурацию в файл. Файл с расширением cf.
  10. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    я в курсе) сейчас)
  11. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    не дают прав загрузки файла
  12. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Что не дают? Пишите точнее, а то у меня такое ощущение, что мы вообще на разных языках разговариваем. Это же форум. Здесь не видно выражение вашего лица, не видно какие ошибки у Вас появляются и не видно, что вы делаете.
  13. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Да здесь, на форуме, не дают прав для загрузки файла,
    содержащего конфигурацию.
  14. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    В архив запакуйте (желательно zip).
  15. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    в rar её запакуйте

    [warn=Внимание!]
    Лучше zip. Связанно с некоторыми, скажем так, особенностями работы форума.
    [/warn]
  16. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1

    Вложения:

    • 1Cv8.zip
      Размер файла:
      875,1 КБ
      Просмотров:
      24
  17. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Сейчас по обедаю и погляжу.
  18. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Приятного аппетита!
  19. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Спасибо.

    Я вот что-то не понял. Зачем у Вас при проведении документ приход данные записываются в документ расход? И еще раз точнее сформулируйте задачу.
  20. TopicStarter Overlay
    Реалистка
    Offline

    Реалистка

    Регистрация:
    17 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Разве?
    По-моему, там все норм проводится. В нужное место.
    В общем, открываю документ расход.
    Ставлю количество и сумму сама, а в колонке цена должна ставится автоматом так называемая средняя цена.
    Этого от меня требует бухгалтер.
    Формулу я вам кинула.
    Пробовала и через регистр накопления как-то ее вывести, и через программный код в табличной части формы документа расход. Или я тупая, или лыжи не едут.

Поделиться этой страницей