7.7 Сравнение строчек

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Ugrumi, 26 окт 2007.

  1. TopicStarter Overlay
    Ugrumi
    Offline

    Ugrumi Опытный в 1С

    Регистрация:
    8 окт 2007
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    Проблем в названии фирмы, в справочнике забита фирма с названием таким (ООО "Сибирьконтракт")
    Мне нужно установить фильтр:
    Если Фирма=("ООО "Сибирьконтракт"") Тогда
    Номер="АС-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "Барнаульский"+ ЗКПД"") Тогда
    Номер="АБ-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "БЗКПД"") Тогда
    Номер="АД-"+"0001";
    КонецЕсли;

    Мне выдает такую вот ошибку: "Ожидается символ ')' " если без скобок тогда (Ожидается "then\тогда "). Подскажите пожайлусто как бороться с такой бедой?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    Если Фирма = ("ООО " + """Барнаульский"""+ """ЗКПД""") Тогда
    
    Сравнивает с ООО "Барнаульский""ЗКПД"

    Код:
    Если Фирма = ("ООО " + """Барнаульский"""+ " ЗКПД")  Тогда 
    
    Сравнивает с ООО "Барнаульский" ЗКПД
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Во первых надо сравнивать:
    фирма.Наименование=("ООО " + """Барнаульский"""+ """ЗКПД""")
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Если у него Фирма не строка - потом само вывалиться :)
  5. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Ссори не подумал :unsure:

Поделиться этой страницей