7.7 Сравнение справочника и строки из ТЗ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Mikin, 28 ноя 2014.

  1. TopicStarter Overlay
    Mikin
    Offline

    Mikin Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Добрый день. В 7.7 почти ничего не понимаю, поэтому подскажите пожалуйста. Загружаю данные из Excel в форму обработки .

    Попытка
    Ехсел=СоздатьОбъект("Excel.Application");
    Исключение
    Предупреждение("Excel на компьютере не установлен!");
    Возврат ПолучитьПустоеЗначение();
    КонецПопытки;
    Книга=Ехсел.Workbooks;
    Книга.Open(Сокрлп(ИмяФайла));
    Диапозон=Ехсел.Sheets(Лист).Cells;
    Строк =Диапозон.SpecialCells(11).Row;
    Столбцов=Диапозон.SpecialCells(11).Column;
    НужныйЛист=Ехсел.Sheets(Лист);

    ехсельТЗ=СоздатьОбъект("ТаблицаЗначений");
    Для Столб=1 По Столбцов Цикл
    ехсельТЗ.НоваяКолонка();
    КонецЦикла;

    Спр = СоздатьОбъект("Справочник.Материалы");
    Спр.ВыбратьЭлементы();

    Для Стр=1 По Строк Цикл
    Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));
    ехсельТЗ.НоваяСтрока(Стр);
    Для Столб=1 По Столбцов Цикл
    ЗначениеЕксель=СокрЛП(НужныйЛист.Cells(Стр,Столб).text);
    Если ПустаяСтрока(ЗначениеЕксель)=0 Тогда
    Пока Спр.ПолучитьЭлемент() = 1 Цикл // получая первый элемент из excel заходим в справочник материалы обходим его весь. Но когда цикл завершается больше мы сюда не заходит. Почему ?
    Если Спр.Код <> ЗначениеЕксель Тогда
    ехсельТЗ.УстановитьЗначение(Стр,Столб,ЗначениеЕксель);
    КонецЕсли;
    Конеццикла;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

    Книга.Close();
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Бред полный.... Ошибка на ошибке. Даже править не хочется.
    Вот ссылка для примера
    http://1c-pro.ru/threads/kopilka.2093/
    Почитайте.. Если же вы не новичок, а просто не знаете 7ку - отпишитесь... Будем исправлять ваш код....
  3. TopicStarter Overlay
    Mikin
    Offline

    Mikin Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    В 7-ке полный новичек. Привел конечно не весь код, но как бы основная часть которая нужна мне. Спасибо за ссылку, буду изучать.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Будут "непонятки" - спрашивайте...

Поделиться этой страницей