8.х Справочник-сотрудники 7.7 Зарплата и кадры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем shana, 15 окт 2007.

  1. TopicStarter Overlay
    shana
    Offline

    shana

    Регистрация:
    19 сен 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Надо вывести сотрудников которые работают на данный момент.Я че-то загналась. Говорит,Состоянме ФизЛица - не периодический. В чем Ошибка подскажите?? А еще подскажите как вывести оклад и страховой стаж???

    Перем ОписаниеСостояния;
    Перем Периодический;
    Перем СпрНачисленияУдержания;


    //*******************************************
    Процедура Выполнить()
    ТаблицаПечати = СоздатьОбъект("Таблица");
    ТаблицаПечати.ИсходнаяТаблица("Таблица");
    ТаблицаПечати.ВывестиСекцию("Шапка");

    Периодический = СоздатьОбъект("Периодический");
    СпрНачисленияУдержания = СоздатьОбъект("Справочник.НачисленияУдержания");
    Док=СоздатьОбъект("Справочник.Сотрудники");

    Док.ВыбратьЭлементы();
    Пока Док.ПолучитьЭлемент() = 1 Цикл
    Сотр=Док.ТекущийЭлемент();
    ДатаПриема = Дата(0);
    ДатаУвольнения = Дата(0);
    ОписаниеСостояния="";
    ДатаАктуальности = ТекущаяДата();
    Периодический.ИспользоватьОбъект("СостояниеФизлица",Док.ТекущийЭлемент());
    СостояниеФЗ = Периодический.ЗначениеНаДату(ДатаАктуальности);
    Если ПустоеЗначение(СостояниеФЗ)=0 Тогда
    Если Сотр.ОсновнойЭлемент<>Сотр Тогда
    ОписаниеСостояния = "Внутреннее совместительство";
    ИначеЕсли СостояниеФЗ=Перечисление.СостояниеФизлица.СотрудникОсновной Тогда
    ОписаниеСостояния = "Штатный сотрудник";
    ИначеЕсли СостояниеФЗ=Перечисление.СостояниеФизлица.СотрудникНеосновной Тогда
    ОписаниеСостояния = "Внешний совместитель";
    КонецЕсли;
    КонецЕсли;

    Если (ОписаниеСостояния="Штатный сотрудник")или(ОписаниеСостояния="Внешний совместитель") Тогда
    ФИО=Сотр.Наименование;
    Должность=Сотр.Должность.Наименование;
    ДатаР=Сотр.ДатаРождения;
    Оклад=Сотр.Оклад;
    Стаж=Сотр.СтажСтраховой;
    ТаблицаПечати.ВывестиСекцию("Строка");
    ТаблицаПечати.Показать("Таблица");
    КонецЕсли;

    КонецЦикла;

    КонецПроцедуры
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Вам в другую ветку. Эта по 1С 8.

Поделиться этой страницей