7.7 Справочник. Работа с уровнями

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Чешир, 7 фев 2008.

  1. TopicStarter Overlay
    Чешир
    Offline

    Чешир

    Регистрация:
    10 ноя 2006
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Есть справочник (3 уровня). Есть таблица (НазваниеГруппы1,НазваниеГруппы2,НазваниеГруппы3)
    По этим данным нужно найти перую группу. Потом внутри этой ггруппы найти вторую и т.д.
    С первой естественно проблем нет. Но как дальше.
    :unsure: Есть метод "ИспользоватьРодителя" но не совсем понимаю как он работает.
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Код:
    спр=создатьОбъект("Справочник.3Уровня");
    спр1="";
    
    Если спр.НайтиПоНаименованию(НазваниеГруппы1,0,1)=1 тогда
    спр1=спр.ТекущийЭлемент();
    спр.ИспользоватьРодителя(спр1,0);
    Если спр.НайтиПоНаименованию(НазваниеГруппы2,1,1)=1 тогда
    спр1=спр.ТекущийЭлемент();
    спр.ИспользоватьРодителя(спр1,0);
    Если спр.НайтиПоНаименованию(НазваниеГруппы3,1,1)=1 тогда
    ..........................Тут найдена третья группа
    иначе
    сообщить("В группе "+спр1.Наименование+" нет группы "+НазваниеГруппы3)
    КонецЕсли;
    иначе
    сообщить("В группе "+спр1.Наименование+" нет группы "+НазваниеГруппы2)
    КонецЕсли;
    КонецЕсли;
    
    
    
    :unsure:
  3. TopicStarter Overlay
    Чешир
    Offline

    Чешир

    Регистрация:
    10 ноя 2006
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Спасибо. Уже сам разобрался...все так и получается ))

Поделиться этой страницей