7.7 Справочник Контрагенты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Mono, 10 авг 2011.

  1. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Загвостка у новечка. Справочник Котрагенты, для элемента группы сделать печатную форму. Контрагенты, товары, автоскидки

    Как сначало забить в табличую часть-колонку Контрагенты, контрагентов из справочника =)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А теперь пожалуста еще раз и по русски.

    Подозреваю что речь идет о выводе в таблицу всех контрагентов принадлежащих определенной группе? Тогда смотите метод ИспользоватьРодителя
  3. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    ты правильно понял)
    как выглядит часть кода который заполняет таблицу?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Где то так
    Код:
    Процедура Сформировать()
    Если ПустоеЗначение(Группа)=1 Тогда
    Возврат;		
    КонецЕсли;
    Спр=СоздатьОбъект("Справочник.ТоЧтоХочу");
    Спр.ИспользоватьРодителя(Группа);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //тут выводим
    КонецЦикла;
    
    
    КонецПроцедуры
    
    
  5. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Спасибо. ненмого разобрался с этим. =)
    непонимаю как все должно крутиться. есть справичник Контрагенты и Автоскидки(подчинен Контрагенту)
    надо прокрутить Автоскидки и соотнести с контрагентом и вывести. никак не могу представить или с чео начать.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Используте владельца для подчиненного справочника....
  7. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    тоесть я за основу беру подчиненный справочник Автскидки, через процедуру пропускаю его с условием если попадется скидка то соотнести с Контрагентом и вывести в таблицу?
    типо этого =)
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Можно и так.... Тогда условие
    Спр.Владелец.ПринадлежитГруппе

    Иначе для каждого элемента контрагентов нужно применить Спр.ИспользоватьВладельца

    где спр - справочник автоскидки
  9. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Код:
     
    Процедура Проба1()  
    Таб = СоздатьОбъект("ТаблицаЗначений");
    Таб.НоваяКолонка("Контрагенты"); 
    Таб.НоваяКолонка("Товары");
    Таб.НоваяКолонка("Скидки");    
    Если ПустоеЗначение(Группа)=1 Тогда
    Возврат;		
    КонецЕсли;
    СпрАвт=СоздатьОбъект("Справочник.Автоскидки");
    СпрАвт.Владелец.ПринадлежитГруппе;
    СпрАвт.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //выводим уже здесь в таблицу?
    КонецЦикла;
    
    
    
    КонецПроцедуры
    
    
  10. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    как то тут все криво. пцц не укладывается в голове
  11. TopicStarter Overlay
    Mono
    Offline

    Mono

    Регистрация:
    18 май 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Проба1()  
    Таб = СоздатьОбъект("ТаблицаЗначений");
    Таб.НоваяКолонка("Контрагенты"); 
    Таб.НоваяКолонка("Товары");
    Таб.НоваяКолонка("Скидки");    
    Спр=СоздатьОбъект("Справочник.Автоскидки");
    Спр.ИспользоватьВладельца(Контрагенты);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()>0 Цикл
    //тут новерное надо записать в таблицу?
    КонецЦикла;
    
    КонецПроцедуры
    
    
    посмотри первые шаги. ))
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если контрагеты - элемент справочника, а не группа - выберет

Поделиться этой страницей