7.7 СПО "еФарма"

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Konrad, 4 фев 2008.

  1. Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    поторопился видать почему то все добавляется все в один док
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ефарма довольно специфическая конфа.
    Давайте по шагам что делаете и что именно не получается.
  3. Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    Создали новую ПБ сделали между ЦБ и ПБ обмен все прошло хорошо, когда в ЦБ делаем перемещение в отдел к которой привязан ПБ выходит "Не обнаружен буферный документ, перенаправление невозможно"
    Затем в конфе нашел процедуру перенаправления
    Код:
    Функция глПеренаправитьДокумент(Конт,лчРежимПоиска = 0) Экспорт
    кнтКонт = Конт;
    Если Конт.Выбран() = 1 Тогда
    лчДокументЗаписан = 1;
    Иначе
    лчДокументЗаписан = 0;
    КонецЕсли;
    Если (Конт.Вид() = "РегистрацияСчета_фактуры") или (Конт.Вид() = "Счет_фактура") Тогда
    Если Конт.ДокументОснование.Выбран() = 1 Тогда
    
    лдокДокументОснование = СоздатьОбъект("Документ." + Конт.ДокументОснование.Вид());
    
    Если лдокДокументОснование.НайтиДокумент(Конт.ДокументОснование) = 1 Тогда
    кнтКонт = лдокДокументОснование.ТекущийДокумент();
    Иначе
    
    Сообщить("Не найден документ-основание (" + Конт.ДокументОснование + ") для поиска реквизита перенаправления. Перенаправление невозможно!","!");
    СтатусВозврата(0);
    
    КонецЕсли;
    
    Иначе
    
    Сообщить("Не заполнен документ-основание у документа """ + Конт.ТекущийДокумент() + """! Перенаправление невозможно!","!");
    СтатусВозврата(0);
    
    КонецЕсли;
    Если СтатусВозврата() = 0 Тогда
    Возврат 0;
    КонецЕсли;
    КонецЕсли;
    лспрЗначениеАтрибута = "";
    Если глНеобходимоПеренаправить(Конт, лспрЗначениеАтрибута) = 1 Тогда
    лдок = СоздатьОбъект("Документ." + Конт.Вид());
    лдок.ВыбратьДокументы(глдНачалоИнтервалаХраненияБуферныхДокументов,глдОкончаниеИнтервалаХраненияБуферныхДокументов);
    лчНашлиДокумент = 0;
    лдокИзБуфера    = СоздатьОбъект("Документ." + Конт.Вид());
    Пока лдок.ПолучитьДокумент() = 1 Цикл
    
    Если ИБСозданияОбъекта(лдок.ТекущийДокумент()) = лспрЗначениеАтрибута.КодИБ Тогда
    
    лчНашлиДокумент = 1;
    Прервать;
    
    КонецЕсли;
    
    КонецЦикла;
    Если лчНашлиДокумент = 1 Тогда
    
    Если лдокИзБуфера.НайтиДокумент(лдок.ТекущийДокумент()) = 1 Тогда
    
    лдокИзБуфера.НомерДок = Конт.НомерДок;
    лдокИзБуфера.ДатаДок  = Конт.ДатаДок;
    
    лчЧасы    = 0;
    лчМинуты  = 0;
    лчСекунды = 0;
    
    ТекущееВремя(лчЧасы,лчМинуты,лчСекунды);
    
    лдокИзБуфера.УстановитьВремя(лчЧасы,лчМинуты,лчСекунды);
    
    Для лчИндекс = 1 по Метаданные.ОбщийРеквизитДокумента() Цикл
    
    лсИмяАтрибута = Метаданные.ОбщийРеквизитДокумента(лчИндекс);
    лдокИзБуфера.УстановитьАтрибут(лсИмяАтрибута,Конт.ПолучитьАтрибут(лсИмяАтрибута));
    
    КонецЦикла;
    
    Для лчИндекс = 1 по Метаданные.Документ(Конт.Вид()).РеквизитШапки() Цикл
    
    лсИмяАтрибута = Метаданные.Документ(Конт.Вид()).РеквизитШапки(лчИндекс);
    лдокИзБуфера.УстановитьАтрибут(лсИмяАтрибута,Конт.ПолучитьАтрибут(лсИмяАтрибута));
    
    КонецЦикла;
    
    Конт.ВыбратьСтроки();
    
    Пока Конт.ПолучитьСтроку() = 1 Цикл
    
    лдокИзБуфера.НоваяСтрока();
    
    Для лчИндекс = 1 по Метаданные.Документ(Конт.Вид()).РеквизитТабличнойЧасти() Цикл
    
    лсИмяАтрибута = Метаданные.Документ(Конт.Вид()).РеквизитТабличнойЧасти(лчИндекс);
    лдокИзБуфера.УстановитьАтрибут(лсИмяАтрибута,Конт.ПолучитьАтрибут(лсИмяАтрибута));
    
    КонецЦикла;
    
    КонецЦикла;
    
    Попытка		  
    
    Если лчДокументЗаписан = 0 Тогда
    лдокИзБуфера.Записать();
    КонецЕсли;
    
    Если (лдокИзБуфера.Вид() = "Заявка") и (лчРежимПоиска = 1) Тогда
    Возврат лдокИзБуфера.ТекущийДокумент();
    КонецЕсли;
    
    Если лчРежимПоиска = 1 Тогда
    Возврат 1;
    КонецЕсли;
    
    // Указатель: НАЧАЛО БЛОКА Автор: Беляев Р.А. Дата: 21/07/2006 SCR #1027-1090
    //8 закомментировать блок после реализации SCR #1027-1090
    Попытка
    лспрРС = СоздатьОбъект("Справочник.РегиональныеСертификаты");
    Исключение
    
    Если (лдокИзБуфера.Вид() = "Приходная") Или (лдокИзБуфера.Вид() = "ПеремещениеВРозницу") Тогда
    
    НачатьТранзакцию();
    
    глСохранитьПартии(лдокИзБуфера);  //8 Временно оставлено !!!
    
    ЗафиксироватьТранзакцию();
    
    КонецЕсли;
    
    КонецПопытки;
    //8 закомментировать блок после реализации SCR #1027-1090
    // Указатель: КОНЕЦ БЛОКА Автор: Беляев Р.А. Дата: 21/07/2006 SCR #1027-1090
    
    Если ТипЗначения(Конт) = 100 Тогда
    
    СтатусВозврата(0);
    Конт.Форма.Закрыть(0);
    
    Если лчДокументЗаписан = 1 Тогда
    лдокКонт = СоздатьОбъект("Документ." + Конт.Вид());
    Если лдокКонт.НайтиДокумент(Конт) = 1 Тогда
    
    лдокКонт.Удалить(0);
    
    лСтараяДата		  = лдокКонт.ДатаДок;
    лдокКонт.ДатаДок	 = ДобавитьМесяц(лСтараяДата, -120);
    лсКомментарий = СокрЛП(лдокКонт.Комментарий);
    
    Если СтрДлина(лсКомментарий) > 0 Тогда
    
    Если Прав(лсКомментарий, 1) = ";" Тогда
    лсКомментарий = лсКомментарий + "Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    Иначе
    лсКомментарий = лсКомментарий + ";Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    КонецЕсли;
    
    Иначе
    лсКомментарий = лсКомментарий + "Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    КонецЕсли;
    
    лдокКонт.Записать();
    лдокИзБуфера.Записать();
    
    КонецЕсли;
    
    КонецЕсли;
    
    Конт = "";
    ОткрытьФорму(лдокИзБуфера.ТекущийДокумент(),Конт);
    
    ИначеЕсли ТипЗначения(Конт) = 12 Тогда
    
    Если лчДокументЗаписан = 1 Тогда
    лдокКонт = СоздатьОбъект("Документ." + Конт.Вид());
    Если лдокКонт.НайтиДокумент(Конт) = 1 Тогда
    
    лдокКонт.Удалить(0);
    
    лСтараяДата		  = лдокКонт.ДатаДок;
    лдокКонт.ДатаДок	 = ДобавитьМесяц(лСтараяДата, -120);
    лсКомментарий = СокрЛП(лдокКонт.Комментарий);
    
    Если СтрДлина(лсКомментарий) > 0 Тогда
    
    Если Прав(лсКомментарий, 1) = ";" Тогда
    лсКомментарий = лсКомментарий + "Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    Иначе
    лсКомментарий = лсКомментарий + ";Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    КонецЕсли;
    
    Иначе
    лсКомментарий = лсКомментарий + "Перенаправлен " + лдокКонт.НомерДок + " " + лдокКонт.ДатаДок + ";";
    КонецЕсли;
    
    лдокКонт.Записать();
    лдокИзБуфера.Записать();
    
    КонецЕсли;
    КонецЕсли;
    
    Конт = лдокИзБуфера;
    
    КонецЕсли;
    
    Исключение
    
    Сообщить("Не удалось перенаправить документ """ + Конт.ТекущийДокумент() + """ по причине:");
    Сообщить(ОписаниеОшибки(),"!");
    СтатусВозврата(0);
    Возврат 0;
    
    КонецПопытки;
    
    КонецЕсли;
    
    Сообщить("Перенаправление документа """ + Конт.ТекущийДокумент() + """ произведено!", "i");
    Возврат 1;
    
    Иначе  
    
    Сообщить("Не обнаружен буферный документ, перенаправление невозможно!","!");
    СтатусВозврата(0);
    Возврат 0;
    
    КонецЕсли;
    КонецЕсли;
    Возврат 2;
    КонецФункции // глПеренаправитьДокумент()

    в выборке есть интервал дат стоит 01.01.1990 по 01.01.1995 я изменил на 2010 и 2015 решил попробовать все документы создаются при том что док из ПБ должен быть непроведенным, потом заметил что все что я добавляю вновь созданный документ дублируется в док из ПБ
  4. jah187
    Offline

    jah187

    Регистрация:
    31 май 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Доброго дня всем. Сегодня узнал, что нужно сделать годовой отчет по ЖНВЛС за 2012г. Может быть есть у кого обработка для Е-Фармы заточенная под этот отчет?
  5. Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    Кто как борится с проблемой Не обнаружен буферный документ, перенаправление невозможно!
  6. Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    У меня московская редакция Ефармы я так понял что есть еще свердловская и они не много отличаются, там такая же проблема с буфером?
  7. jah187
    Offline

    jah187

    Регистрация:
    31 май 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Кто-то делал свертку базы в е-Фарме на 1С 7.7? Может быть есть у кого-то обработки для свертки? Или хотя бы подскажите как можно ускорить процесс
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Насколько я знаю - ее нет. Заказывали мне обрезку. Делал через перенос справочников/остатков в чистую БД.
  9. jah187
    Offline

    jah187

    Регистрация:
    31 май 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А сколько по времени это все заняло? Можете сказать? Просто я жестко ограничен во времени. До меня все это делалось самописной обработкой, которая сначала формирует остатки, потом помечает на удаление старые документы, затем проводит документы с остатками. Занимает этот весь процесс двое суток, примерно, а времени есть всего лишь 9 часов. Ну и если попросить Вас о помощи, в какую сумму мне это все выйдет, если конечно у Вас есть время.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Ориентировочно 30мин-1час. Нужно же протестировать результат.
    2) По второму вопросу - в аську. Коммерческие проекты на данном форуме не рассматриваются
  11. TopicStarter Overlay
    Konrad
    Offline

    Konrad Опытный в 1С

    Регистрация:
    4 фев 2008
    Сообщения:
    61
    Симпатии:
    1
    Баллы:
    29
    С 1 января вступил в действие закон, по которому даже ЕНВДшники обязаны сдавать в налоговую Книги покупок. А это значит, что необходимо учитывать счета-фактуры поставщиков. Книга покупок формируется в 1С:Бухгалтерии (у нас 7.7).
    Неделю голову ломаю, не могу придумать какой регламент организовать. Сначала сделал для заведующих аптек в приходной три новых поля, которые обязали их заполнять: номер, дата счёт-фактуры и ндс по счёту-фактуре. Теперь вот выясняется, что НДС 10% и 18% надо вводить раздельно.
    Кто что делал, чтобы информация о входящих счетах-фактурах попадала в Бухню? Или у вас бухгалтера сами каждую сч/фактуру ручками обрабатывают?
    Более глобальный вопрос: как у кого организована перегрузка информации из ефармы в бухгалтерию? Стандартными обработками или свои разработки используете?
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В поступлении указывается НДС... Там и 0, 10 и 18...
    Я писал правила обмена в КД на заказ.
  13. Светялчок
    Offline

    Светялчок

    Регистрация:
    18 фев 2014
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Стоит е-фарма 7.7 (ред 1,2 от 2010г). Подскажите, пожалуйста, сам механизм инвентаризации, каков порядок заведения документов? Спасибо!
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Насколько я помню там из отчета по остаткам можно создать инвентаризацию.
    Светялчок нравится это.
  15. TopicStarter Overlay
    Konrad
    Offline

    Konrad Опытный в 1С

    Регистрация:
    4 фев 2008
    Сообщения:
    61
    Симпатии:
    1
    Баллы:
    29
    Изначально разработчики предполагали проведение инвентаризации через Сервис - Служебные обработки - Фоновая инвентаризация.
    Там сначала создаёте "Начало инвентаризации", затем весь товар сканируете во "Вводе остатков", затем заканчиваете через "Завершение инвентаризации". Но вот у нас последний этап не работал изначально. Если хотите, расскажу, как у нас делается.
    Светялчок нравится это.
  16. Светялчок
    Offline

    Светялчок

    Регистрация:
    18 фев 2014
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Буду признательна.
    --- Объединение сообщений, 4 фев 2015 ---
    поподробнее не расскажете? спасибо!
  17. Светялчок
    Offline

    Светялчок

    Регистрация:
    18 фев 2014
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Коллеги, расскажите, пожалуйста, поподробнее!!! Спасибо!
  18. TopicStarter Overlay
    Konrad
    Offline

    Konrad Опытный в 1С

    Регистрация:
    4 фев 2008
    Сообщения:
    61
    Симпатии:
    1
    Баллы:
    29
    1. До инвентаризации проверяете, все ли документы проведены: приходные, расходные, смены, и всевозможные акты. Можно сделать резервную копию базы.
    2. Открываете инвентаризацию: Сервис - Служебные обработки - Фоновая инвентаризация. Выбираете отдел, по которому проводится инвентаризация, выставляете количество строки в описи (мы ставим 45 - как раз убирается на лист А4). Нажимаете "Начало инвентаризации". Создаётся служебный документ "Начало инвентаризации".
    3. Далее мы на кассах заходим под ФИО заведующей (уровень прав - Пользователь). Идём опять в Сервис - Служебные обработки - Фоновая инвентаризация - выбираем отдел - Ввод остатков. На кассах фармацевты штрихуют сканерами весь товар.
    4. В это время мы подключаем к компьютеру с базой переносной сканер (Терминал сбора данных), настраиваем его работу через меню Сервис - Настройка торгового оборудования.
    5. С компа заведующей в ходе инвентаризации распечатываем ведомости (документ Инвентаризация), можно по ним перепроверять правильность сканирования товара прямо в ходе инвентаризации, или после завершения сканирования. Всё зависит от количества работников.
    6. Найденные ошибки исправлять можно через кнопку "Корректировка данных", но мы предпочитаем корректировать непосредственно в ведомостях, которые попадают в Журнал - Инвентаризация - Журнал инвентаризаций.
    7. Далее, по замыслу разработчиков нужно нажать "Завершение инвентаризации". В ходе этой процедуры программа проводит ведомости, сравнивает остаток товаров по программе с отштрихованным товаром. На основе этих данных формирует 2 документа: акт недостачи и акт излишек. Затем проводит их. Но у нас это не работает - программа вываливается с ошибками на этапе проведения актов из-за различных ошибок, накопившихся в ходе работы программы (различия по остаткам между регистрами ДоступныеОстатки и ОстаткиТоваров).
    8. Поэтому мы делаем по-другому: проводим ведомости самостоятельно через Сервис - Обработка документов (Вид документов - Инвентаризация, Действие - Провести, Обрабатывать - не помеченные на удаление). Затем от документа НачалоИнвентаризации вводим на основании два акта: акт недостачи и акт излишек.
    9. У нас просто так эти акты не проводятся, потому что базы непрерывно ведутся уже шестой год, и накопились различные ошибки. Поэтому приходится обрабатывать эти акты вручную, удаляя некорректные строки.... но это уже другая история...
    10. Распечатываем получившиеся акты, а также и из документа НачалоИнвентаризации инвентаризационную опись (полный список всего что было просканировано).


    Примечания:
    - иногда во время выгрузки с переносного сканера случаются беспричинные вылеты, есть подозрение, что связаны с одновременным сканированием товара на кассах, приходится выгружать заново и удалять задублировавшиеся ведомости;
    - кто-то, возможно найдёт удобным функционал "Печать описных листов" и "Сличительная ведомость". Мы не используем их.
    - поскольку мы не используем "Завершение инвентаризации", то предыдущие инвентаризации у нас считаются не завершёнными, и на следующий год при инвентаризации приходится у ведомостей менять обработкой документ-основание.

    Вопросы?
  19. Светялчок
    Offline

    Светялчок

    Регистрация:
    18 фев 2014
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо Вам огромное!!!!!!!!!!!!!!! ПРЕОГРОМНОЕ!!!!!!!!!!!!! Вопросов нет) Будем пробовать)))
  20. ryazanov_da
    Offline

    ryazanov_da

    Регистрация:
    29 июл 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    скайп: ryazanov_da стучитесь, обменяемся опытом... Ефарма 7.7 (работаю с ней 9 лет)

Поделиться этой страницей