7.7 список на зачисление средств

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем denn-m, 30 ноя 2010.

  1. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! 1с предприятие 7.7 бухгалтерский учет
    подскажите как изменить в журналы->зарплата->список на зачисление средств в окошке "номер файла" ставится число макс.9, как сделать чтобы можно было ставить 999?

    Вложения:

  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Похоже нужно просто увеличить длину реквизита
  3. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    как это сделать?
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Найти эту обработку в конфигураторе, зайти в свойства этого реквизита и изменить его длину.
    [off]Судя по вопросу, рекомендую сначала сделать копию базы. Возможно даже потренироваться на копии.[/off]
  5. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    подскажите где она находится, а то не могу найти?
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Я не подскажу. Этой типовой не знаю и нет под рукой. Если до вечера никого не будет - выложи на файлообменник МДшник, и дай ссылку. Посмотрим...
  7. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    нашел, напишите где надо изменить?

    Код:
    Перем ИдентОтчета;
    Перем ИмяФайла;
    
    //******************************************************************************
    Процедура СформироватьИмяФайла()
    День         = Формат(ДатаЧисло(рд_ДатаФормирования),"Ч(0)2");
    Месяц        = Формат(ДатаМесяц(рд_ДатаФормирования),"Ч(0)2");
    КодОтделения = рд_КодыОтделений.ПолучитьЗначение(рд_КодыОтделений.ТекущаяСтрока());
    ИмяФайла     = "p" + рд_КодПредприятия + День + Месяц + НомерФайла + "." + СокрЛП(КодОтделения);
    Форма.кнОткрыть.Доступность(ФС.СуществуетФайл(ПутьКФайлу + ИмяФайла));
    КонецПроцедуры
    
    //******************************************************************************
    Процедура Выгрузить(Докум)
    Таб = СимволТабуляции;
    Файл = СоздатьОбъект("Текст");
    Файл.КодоваяСтраница(0);
    
    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку() = 1 Цикл
    Сотрудник = Докум.Сотрудник;
    
    Если ПустоеЗначение(Сотрудник.НомерЗарплатногоСчета) = 1 Тогда
    Сообщить("У сотрудника "+СокрЛП(Сотрудник)+" не указан номер зарплатного счета, пропущен");
    Продолжить;
    Иначе
    Если СтрДлина(СокрЛП(Сотрудник.НомерЗарплатногоСчета)) < 20 Тогда
    Сообщить("Неверная длина номера зарплатного счета сотрудника "+СокрЛП(Сотрудник)+", пропущен","!!!");
    Продолжить;
    КонецЕсли;
    КонецЕсли;
    
    Если Докум.КВыдаче = 0 Тогда
    Продолжить;
    КонецЕсли;
    
    Стр = 
    //Сотрудник.НомерЗарплатногоСчета+"-56" + Таб +
    Сотрудник.НомерЗарплатногоСчета + Таб +
    Формат(Докум.КВыдаче,"Ч9.2.") + Таб + 
    Врег(Лев(СтрЗаменить(Сотрудник.Наименование,"  ",""),48));
    
    Файл.ДобавитьСтроку(Стр);
    КонецЦикла;
    
    Файл.Записать(ПутьКФайлу+ИмяФайла);
    Сообщить("Сформирован файл " + (ПутьКФайлу+ИмяФайла),"i");
    Форма.кнОткрыть.Доступность(ФС.СуществуетФайл(ПутьКФайлу + ИмяФайла));
    КонецПроцедуры
    
    //******************************************************************************
    Процедура ПоКнопкеВыгрузить()
    Если Док.Выбран() = 0 Тогда
    Предупреждение("Не выбран документ!", 60);
    Возврат;
    КонецЕсли;
    
    Если (Док.Вид() <> "ВыплатаЗПКасса") и (Док.Вид() <> "ВыплатаБанк") Тогда
    Возврат;
    КонецЕсли;
    
    Выгрузить(Док);
    КонецПроцедуры // ПоКнопкеПечать()
    
    //******************************************************************************
    Процедура ВыборКаталога(ИмяКаталога)
    Если ФС.ВыбратьКаталог(ИмяКаталога, "Выберите каталог") = 1 Тогда
    ПутьКФайлу = ИмяКаталога+"\";
    Форма.кнОткрыть.Доступность(ФС.СуществуетФайл(ПутьКФайлу + ИмяФайла));
    КонецЕсли;                                                           
    КонецПроцедуры
    
    //******************************************************************************
    Процедура ОткрытьФайлДляПросмотра(ИмяФайлаДляПросмотра)
    Если ФС.СуществуетФайл(ИмяФайлаДляПросмотра) = 1 Тогда 
    Файл = СоздатьОбъект("Текст");
    Файл.Открыть(ИмяФайлаДляПросмотра);
    Файл.Показать("Реестр на открытие счетов",ИмяФайлаДляПросмотра);
    Иначе 
    Предупреждение("Файл с таким именем не существует!");					
    КонецЕсли;    
    КонецПроцедуры
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриНачалеВыбораЗначения(ИдЭлементаДиалога, Фл)
    Если ИдЭлементаДиалога = "ПутьКФайлу" Тогда
    ВыборКаталога(ПутьКФайлу);
    КонецЕсли;
    КонецПроцедуры
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()
    РасположениеФайла(,ИдентОтчета);
    НазваниеОтчета = СтрЗаменить(ИдентОтчета,".ert","");
    ИдентОтчета    = СтрЗаменить(НазваниеОтчета," ","_");
    
    рд_ДатаФормирования = РабочаяДата();
    НомерФайла = 1;
    
    КодОтделения      = ВосстановитьЗначение(ИдентОтчета+"_КодОтделения");
    рд_КодыОтделений.ТекущаяСтрока(?(ПустоеЗначение(КодОтделения) = 0,КодОтделения,1));
    рд_КодПредприятия = ВосстановитьЗначение(ИдентОтчета+"_КодПредприятия");
    ПутьКФайлу        = ВосстановитьЗначение(ИдентОтчета+"_ПутьКФайлу");
    Если ПустоеЗначение(ПутьКФайлу) = 1 Тогда
    ПутьКФайлу = КаталогПользователя();
    КонецЕсли;
    
    СформироватьИмяФайла();
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    Докум = Форма.Параметр.Получить("Контекст");
    Док = Докум.ТекущийДокумент();
    КонецЕсли;
    
    КонецПроцедуры // ПриОткрытии()
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриЗакрытии()
    СохранитьЗначение(ИдентОтчета+"_КодОтделения",  рд_КодыОтделений.ТекущаяСтрока());
    СохранитьЗначение(ИдентОтчета+"_КодПредприятия",рд_КодПредприятия);
    СохранитьЗначение(ИдентОтчета+"_ПутьКФайлу",    ПутьКФайлу);
    КонецПроцедуры
    
    //******************************************************************************
    //
    рд_КодыОтделений.ДобавитьЗначение(200,"№8615 Кемерово");
    рд_КодыОтделений.ДобавитьЗначение(212,"№2356 Анжеро-Судженск");
    рд_КодыОтделений.ДобавитьЗначение(214,"№2359 Белово");
    рд_КодыОтделений.ДобавитьЗначение(218,"№2364 Ленинск-Кузнецкий");
    рд_КодыОтделений.ДобавитьЗначение(222,"№7388 Мариинск");
    рд_КодыОтделений.ДобавитьЗначение(207,"№7763 Междуреченск");
    рд_КодыОтделений.ДобавитьЗначение(217,"№2363 Новокузнецк");
    рд_КодыОтделений.ДобавитьЗначение(221,"№7387 Прокопьевск");
    рд_КодыОтделений.ДобавитьЗначение(210,"№6244 Таштагол");
    рд_КодыОтделений.ДобавитьЗначение(206,"№5963 Юрга");
    
    сам разобрался, спасибо за помощь.

Поделиться этой страницей