7.7 Список контрагентов конкретного менеджера

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Zeliboba6600, 26 сен 2011.

  1. TopicStarter Overlay
    Zeliboba6600
    Offline

    Zeliboba6600

    Регистрация:
    26 сен 2011
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте уважаемые!
    Написал код обработки,которая по выбранному в поле ввода на форме манагеру должна выводить список его контрагентов. Ну вообщем она не работает:

    <<?>>КонецПопытки;
    {C:\DOCUMENTS AND SETTINGS\ADM1C\РАБОЧИЙ СТОЛ\МЕНЕДЖЕРЫ.ERT(17)}: Ожидается ключевое слово 'Исключение' ('Except')
    ФизЛица = ВыборкаСправочникаКонтрагенты.ОсновноеСвойство.ЗначениеСвойства <<?>>;
    {C:\DOCUMENTS AND SETTINGS\ADM1C\РАБОЧИЙ СТОЛ\МЕНЕДЖЕРЫ.ERT(20)}: Ожидается ключевое слово 'Тогда' ('Then')
    <<?>>тогда
    {C:\DOCUMENTS AND SETTINGS\ADM1C\РАБОЧИЙ СТОЛ\МЕНЕДЖЕРЫ.ERT(21)}: Неопознанный оператор
    <<?>>КонецЦикла;
    {C:\DOCUMENTS AND SETTINGS\ADM1C\РАБОЧИЙ СТОЛ\МЕНЕДЖЕРЫ.ERT(23)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')


    Укажите пожалуйста новичку его ошибку:

    Код:
    Процедура Сформировать()   
    
    ВыборкаСправочникаКонтрагенты = СоздатьОбъект("Справочник.Контрагенты"); 	
    ВыборкаСправочникаКонтрагенты.ВыбратьЭлементы();       
    ПечТабл = СоздатьОбъект("Таблица");
    ПечТабл.ИсходнаяТаблица("СписокКонтрагентов");
    Пока ВыборкаСправочникаКонтрагенты.ПолучитьЭлемент()=1 Цикл  
    
    Попытка 
    Контрагент = ВыборкаСправочникаКонтрагенты.ЮрФизЛицо.Наименование;
    Ответственный = ВыборкаСправочникаКонтрагенты.ОсновноеСвойство.ЗначениеСвойства;
    
    //Исключение  
    //	Ответственный = "-"; 
    //	Контрагент    = "-"; 
    КонецПопытки; 
    
    Если 
    ФизЛица = ВыборкаСправочникаКонтрагенты.ОсновноеСвойство.ЗначениеСвойства;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">	тогда					</span>
    ПечТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    ПечТабл.Показать("Список контрагентов с менеджерами","");  
    КонецПроцедуры
    
    
    Где мои ошибки?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Ошибка в комментировании конструкции исключения
    Код:
    Процедура Сформировать()   
    
    ВыборкаСправочникаКонтрагенты = СоздатьОбъект("Справочник.Контрагенты"); 	
    ВыборкаСправочникаКонтрагенты.ВыбратьЭлементы();       
    ПечТабл = СоздатьОбъект("Таблица");
    ПечТабл.ИсходнаяТаблица("СписокКонтрагентов");
    Пока ВыборкаСправочникаКонтрагенты.ПолучитьЭлемент()=1 Цикл  
    
    Попытка 
    Контрагент = ВыборкаСправочникаКонтрагенты.ЮрФизЛицо.Наименование;
    Ответственный = ВыборкаСправочникаКонтрагенты.ОсновноеСвойство.ЗначениеСвойства;
    
    Исключение  
    Ответственный = "-"; 
    Контрагент    = "-"; 
    КонецПопытки; 
    
    Если 
    ФизЛица = ВыборкаСправочникаКонтрагенты.ОсновноеСвойство.ЗначениеСвойства;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">	тогда					</span>
    ПечТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    ПечТабл.Показать("Список контрагентов с менеджерами","");  
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    Zeliboba6600
    Offline

    Zeliboba6600

    Регистрация:
    26 сен 2011
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Еще вопрос:правильно ли я вывожу каждую выбранную строку в таблицу? Таблица пустая получается
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Внешне я не вижу ошибки. Но неизвестно что у вас в таблице. Выложите сам отчет
  5. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    пока есть
    если есть
    конец если нет
    конец цикла есть
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    условие исключения.... но для чего?
  7. TopicStarter Overlay
    Zeliboba6600
    Offline

    Zeliboba6600

    Регистрация:
    26 сен 2011
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Проблема решена,Всем спасибо,тему можно закрыть

Поделиться этой страницей