8.х Список элементов управления формой

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем axe3, 31 июл 2009.

  1. TopicStarter Overlay
    axe3
    Offline

    axe3

    Регистрация:
    30 июл 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Появилась такая задача, создать словарь в 1С Управление Торговлей. Справочник, 2 колонки - русский вариант написания, вторая - английский. Вот какой вопрос, можно ли реализовать заполнение первой колонки значениями списков элементов управления форм (всех форм конфигурации) через обработку?
    Заранее спасибо за помощь.
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Извратная задача. Не очень понимаю, что вы имеете в виду под списком жлементов управления. Но через метаданные много чего можно достать. Вот пример для справочников:
    Код:
    	
    // перебираем все справочники
    Для каждого Спр Из Метаданные.Справочники Цикл
    // перебираем формы
    Для каждого Форма Из Спр.Формы Цикл
    // получаем форму	
    Форма = Справочники[Спр.Имя].ПолучитьФорму(Форма.Имя);
    // перебираем элементы формы	
    Для й = 0 По Форма.ЭлементыФормы.Количество()-1 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл	</span>
    Сообщить(Форма.ЭлементыФормы.Получить(й).Имя);		
    КонецЦикла; 			
    КонецЦикла; 	
    КонецЦикла; 
    

Поделиться этой страницей