8.х Списание себестоимости

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Тимон, 7 фев 2011.

  1. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Коллеги,нужна помощь.Помогите с примером как прописать в модуле Расходного документа списание товара по фифо и лифо.Вроде прописал-по перому периоду выдает все правильно,а во втором уже периоде программа выдает бред,где может быть ошибка?

    Запись=РегистрыСведений.ПорядокСписания.ПолучитьПоследнее(ЭтотОбъект.МоментВремени());
    Если Запись.Порядок=Перечисления.Порядок.ФИФО тогда
    ТО1.Сортировать("Партия Возр");
    Иначе Запись.Порядок=Перечисления.Порядок.ЛИФО;
    ТО1.Сортировать("Партия Убыв");
    КонецЕсли;
    Для Каждого ТекСтрокаТЧ Из ТЧ Цикл
    Отбор = Новый Структура("Номенклатура",ТекСтрокаТЧ.Номенклатура);
    Строки = То1.НайтиСтроки(Отбор);

    Колво = ТекСтрокаТЧ.Количество;
    Для счет = 0 По Строки.Количество() - 1 Цикл
    Если Колво > 0 Тогда
    Движение = Движения.УчетНоменклатуры.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Номенклатура = Строки[счет].Номенклатура;
    Движение.Партия = Строки[счет].Партия;Если Строки[счет].Количество <= Колво Тогда
    Движение.Количество = Строки[счет].Количество;
    Движение.Сумма = Строки[счет].Сумма;
    Колво = Колво - Строки[счет].Количество;
    Иначе
    Движение.Количество = Колво;
    Движение.Сумма = Строки[счет].Сумма*Колво/Строки[счет].Количество;
    Прервать;
    КонецЕсли;
    Иначе
    Прервать;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
  2. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    ну или свой пример
  3. Isberg
    Offline

    Isberg Опытный в 1С

    Регистрация:
    4 май 2010
    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    26
    Судя по тому что вы хотите просто списать товар с партии, то у вас товар поступает бесплатно и продаете вы его бесплатно :angry:

    А не заметил про цену, но все равно глупо получается :) Ведь списать надо как по УУ так и по БУ/НУ.
  4. Isberg
    Offline

    Isberg Опытный в 1С

    Регистрация:
    4 май 2010
    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    26
    Если что то не то ляпнул, скажите :) А то у меня со списанием тоже проблема, надо списать только по БУ/НУ товар, мучался долго.
  5. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    :angry: ляпнули конечно)я привел часть текста модуля Расх.накладной,где списываю товар по исчислению.Остальное:модуль объекта приходки-движения,в модуле расходки-контроль наличия товара и движение по регистрам...в общем-то все.Списывает неправильно.Мне шеф подсказал сделать через создание в форме ТЗ,выгрузки и свертывания в ней всех данных объекта и потом произвести отбор по товару и фильтр по списанию...но у меня такое ощущение,что можно подкорректировать этот код и он потянет.

    это задача из книги,я начинающий программист,поэтому с реальными задачами еще не особо сталкивался)
  6. Isberg
    Offline

    Isberg Опытный в 1С

    Регистрация:
    4 май 2010
    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    26
    Щас точно не могу посмотреть, но метод списания прописываетсяв запросе (когда выбирается партия для списывания) и на сколько я помню она берется с учетной политики организации (метод списания).
  7. Isberg
    Offline

    Isberg Опытный в 1С

    Регистрация:
    4 май 2010
    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ЗаполнитьЗапросПартийНаСкладахУпр(Запрос, ВестиПартионныйУчетПоСкладам, СтратегияСтатусПартии, СпособОценкиМПЗ)
    
    //Конец кода процедуры
    
    |ГДЕ
    |    СписанныеТовары.Регистратор = &ОсновнойДокумент
    |
    |УПОРЯДОЧИТЬ ПО
    |    ЧислоСерияНоменклатуры,
    |    ЧислоДокументОприходования,
    |    ЧислоЗаказ,
    |    ЧислоСтатусПартии" + ?(СтратегияСтатусПартии = Перечисления.СтретегииСписанияПартийТоваровПоСтатусам.СначалаПринятыеПотомСобственные, " Убыв", "") + ",
    |    ДокументОприходованияДата" + ?(СпособОценкиМПЗ = "ЛИФО", " Убыв","") + ",
    |    ДокументОприходования" + ?(СпособОценкиМПЗ = "ЛИФО", " Убыв","") + "
    |ИТОГИ ПО
    |    НомерСтрокиДокумента";
    КонецПроцедуры
    </span>
    //Берется из структуры
    СпособОценкиМПЗ = СтруктураПараметров.СпособОценкиМПЗУпр;
    
    //Определяется метод списания
    Функция ПолучитьУчетнуюПолитику(МоментКон) Экспорт
    //...
    УчетнаяПолитикаУпр = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(ДатаСрезаОстатков, Отказ,,, Ложь);
    Если НЕ Отказ Тогда
    ТекущаяСтрока.СпособОценкиМПЗУпр = УчетнаяПолитикаУпр.СпособОценкиМПЗ;
    ТекущаяСтрока.ВестиПартионныйУчетПоСкладамУпр = УчетнаяПолитикаУпр.ВестиПартионныйУчетПоСкладам;
    ТекущаяСтрока.СписыватьПартииПриПроведенииДокументовУпр = УчетнаяПолитикаУпр.СписыватьПартииПриПроведенииДокументов;
    ТекущаяСтрока.СтратегияСписанияПоСтатусамУпр = УчетнаяПолитикаУпр.СтратегияСписанияПартийТоваровПоСтатусам;
    ТекущаяСтрока.ВедениеУчетаПоПроектам = УчетнаяПолитикаУпр.ВедениеУчетаПоПроектам;
    ТекущаяСтрока.НеВключатьНДСВСтоимостьПартийУпр = УчетнаяПолитикаУпр.НеВключатьНДСВСтоимостьПартий;
    КонецЕсли;
    
    //...
    
    
    </FONT></FONT></pre>
    Так что все таки метод списания берется с политики организации...

    Так что либо дописывать условие, что если это расходник то списываем по ФИФО... Либо копаемся в учетной политике организации :)
  8. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    спс)))завтра все просмотрю)тогда отвечу что да как получилось)
  9. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    как ни разбирался-не получилось,да и с прогой осяк остался...за это время уже успел новую написать,совсем по другой тематике...в учебках списание по партиям не видел((

Поделиться этой страницей