7.7 Списание остатков товаров

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем 1с-ник, 22 июн 2017.

  1. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Доброго дня.
    Конфигурация - Бухгалтерский учет 4.5

    Можете поделиться обработкой по закрытию счета? Не важно какого, просто интересует синтаксис и этот страшный запрос как это делается именно в семёрке, а также его обработка.Я её лишь несколько раз открывал v7. Вижу, что есть некий объект "Бухгалтерские итоги".

    Бух сказала, чтобы "обработка брала остатки на определенную дату и документом "Отгрузка товаров" выполняла списание товаров в остатке". Вот все "ТЗ". А, ещё вымолвила, что "пытаемся закрыть фирму, которая не работает уже несколько лет".

    В этом доке есть несколько видов отгрузки.
    [​IMG]
    Заметил, что от разного значения этого реквизита формируются разные проводки. Плюс я не совсем понимаю как заполнять шапку. Есть идеи?
    Подскажите, достаточно ли информации предоставил бух и поставьте на путь истинный :)
    Заранее спасибо.

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Код:
    Процедура Сформировать()
        Ит = СоздатьОбъект("БухгалтерскиеИтоги");
        Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ТМЦ, 1); //ТМЦ - фильтр по товару. выбирается в диалоге формы. Не обязателен
        Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, МХ, 1); //МХ - фильтр по местам хранения. выбирается в диалоге формы. Не обязателен
        Ит.ВыполнитьЗапрос(Дат, Дат, "41.1",,, 1,, "СК"); //получим ДО по опту 41.1. Дат - тип дата или документ
        Ит.ВыбратьСубконто(ВидыСубконто.МестаХранения);
        Пока Ит.ПолучитьСубконто(ВидыСубконто.МестаХранения) = 1 Цикл
            //группировка по складу
            Ит.ВыбратьСубконто(ВидыСубконто.Номенклатура);
            Пока Ит.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл
                //группировка по товару
                // Ит.ДО() - сумма товара
                // Ит.ДО(3) - количество
                //если нужно получить конечное сальдо на дату, то вместо ДО используй СКД
            КонецЦикла;
        КонецЦикла;
    КонецПроцедуры
    Последнее редактирование: 23 июн 2017
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    1) Запрос я вым показал выше
    2) Заполнение шапки можно увидеть в процедуре ВводНового соответствующего документа
    3) Контрагента на которого осуществляется отгрузка можно выбирать на форме обработки
    4) Уточните у буха по ценам продажи. Ведь в проводках усредненная себестоимость товара...
  4. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Уточнил по поводу задачи:
    Оказывается, что нужна отгрузка товаров с операцией "Продажа".
    Я смотрю проводки - Дт90.2.1 Кт41.1
    Но остатки то бух просит по 41.2 смотреть!
    Где логика?
    Далее уточняю, говорит, что в проводках ей надо Дт90.2.1 Кт42.1 (т.е. логика всё-таки есть). Тогда зачем документ отгрузки? Может всё же операцией? Не подскажите код по заполнению ручной операции?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Другой документ... Продажа в розницу
  6. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    не работает что-то запрос.
    https://yadi.sk/i/P7PQfA_73KWvsZ
    --- Объединение сообщений, 27 июн 2017 ---
    А, вот СКД вроде пашет... А как обратиться к субконто? Что-то С-П совсем жуткий в отличие от 8рки
  7. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Код:
    Процедура ПриОткрытии()
       
        Спр = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
        Спр.НайтиПоКоду(1);
        ВариантРасчетаНалога = Спр.ТекущийЭлемент();
        Спр = СоздатьОбъект("Справочник.ДвиженияДенежныхСредств");
        Спр.НайтиПоКоду("00018");
        ДвижениеДенежныхСредств = Спр.ТекущийЭлемент();    
        ДатаОстатков = ТекущаяДата();
       
    КонецПроцедуры
    
    //*******************************************
    Процедура Сформировать()
    
        Ит = СоздатьОбъект("БухгалтерскиеИтоги"); 
        Док = СоздатьОбъект("Документ.ПродажаВРозницу");
        Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, , 1);
        Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, , 1);
        Ит.ВыполнитьЗапрос(, ДатаОстатков, "41.2",,, 1,, "СК"); //получим ДО по опту 41.2. Дат - тип дата или документ
        Ит.ВыбратьСубконто(ВидыСубконто.МестаХранения);
      
        Пока Ит.ПолучитьСубконто(ВидыСубконто.МестаХранения) = 1 Цикл
                                                
            Док.Новый();
            //Док.НомерДок.УстановитьНовыйНомер();
            Док.ДатаДок                     = ТекущаяДата();       
            Док.МестоХранения                 = Ит.Субконто(2);
            Док.ПродажаОблагаетсяЕНВД         = 0;
            Док.ВариантРасчетаНалогов          = ВариантРасчетаНалога.ТекущийЭлемент();
            Док.ДвижениеДенежныхСредств     = ДвижениеДенежныхСредств.ТекущийЭлемент();
            Док.Комментарий                 = "Создан автоматически обработкой закрытия";
           
            Ит.ВыбратьСубконто(ВидыСубконто.Номенклатура);
           
            Пока Ит.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл
                                   
                Док.НоваяСтрока();
                Док.Товар                  = Ит.Субконто(1);
                Док.Количество             = Ит.СКД("К");
                Если Ит.СКД("К") = 0 Тогда
                    Док.Цена                = 0;
                Иначе
                    Док.Цена               = Ит.СКД()/Ит.СКД("К");
                КонецЕсли;
                Док.Сумма                  = Ит.СКД();
                Док.НДС                       = СтавкаНДС.ТекущийЭлемент();
                Док.Всего                  = Ит.СКД();
                       
            КонецЦикла;
              
            Док.Записать();
            Док.Провести();
           
        КонецЦикла;   
       
    КонецПроцедуры
    Вроде все ОК. Создались 4 документа по 4 складам.
    Но почему то 2 из них не проводятся по НУ. Куда копать?:(
  8. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Отладка говорит, что нет остатков на Н02.02.1. Что я опять не так делаю?:)
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    или последовательность не восстановлена... или были ручные вводы остатков через бух справку...
    Забей на НУ... Судя по квалификации буха она даже не заметит
    kisol нравится это.
  10. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    И правда - все ОК :)
    Ещё раз спасибо, тему можно закрывать.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    не за что... обращайся
  12. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Последнее редактирование: 2 июл 2017
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    В УСН (если речь идет о конфигурации УСН) специфический план счетов... Там розница-опт хранится на забалансе счета МХ. 41.1 и 41.2 это принимаемые и не принимаемые для НУ
    kisol нравится это.
  14. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Доброго дня.
    УСН 1.3.
    Теперь бух говорит, что при возврате поставщику ей нужны проводки Дт 41,2 (Товары, приним. для НУ) Кт 76,5 (Расч. по расх., не приним. для НУ, в руб.), кои я также не нашёл в стандартных операциях. А ручная операция при создании таковых, информирует, что они не корреспондируют друг с другом и приходится отжимать отбор, чтобы создать проводку.
    Подскажите, пож-та, что хочет бух, адекватная ли это проводка и что она делает :)
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    что бух курила мне интересно? проводка не адекватная
  16. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Наверное, Пырей :)
    А как правильно делать возврат в этой конфе? Весь интернет "прошерстил", а ответа так и не нашёл. Сказал ей, пускай норм задачу ставит.
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
  18. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    А как тогда его заполнить?
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    конкретизируй задачу....
  20. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Есть некий dbf файл с содержанием:
    DATADOK NOMERDOK NAMEDOK KONTRAGENT INN TOVAR10 TOVAR10NDS TOVAR18 TOVAR18NDS TOVAR0 TOVAR0NDS
    где Товар0/10/18 - Сумма без ндс по каждой ставке, а ТоварНДС соответственно сумма НДС по каждому виду.
    Стоит задача загрузить данные и отразить в учете :) Бух не шарит.
    Пришла идея сделать через операцию с проводками типа сторно документа "Поступление МПЗ".
    Т.е. у поступления
    Код:
    Дт МХ.2 | Кт -
    Дт 41.2 | Кт 60.2
    Дт НДС  | Кт -
    А я делаю операцией такие:
    Код:
    Дт -    | Кт МХ2
    Дт 60.2 | Кт 41.2
    Дт -    | Кт НДС
    

Поделиться этой страницей