8.х Создать команду.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Сергей1111, 29 июл 2016.

?

Как прописать действие?

  1. Создать строку

    0 голосов
    0,0%
  2. Ка?

    0 голосов
    0,0%
Можно выбрать сразу несколько вариантов.
  1. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Процедура РаспределитьПривес(Кнопка)
    ЗапросПривес = Новый Запрос();
    ЗапросПривес.Текст = "ВЫБРАТЬ
    | КА_МассаСкота.Масса
    |ИЗ
    | РегистрСведений.КА_МассаСкота КАК КА_МассаСкота";
    Привес=Взвешивание.ВыгрузитьКолонки("Привес");
    ЗапросПривес.УстановитьПараметр("Привес", Привес);
    ТабВзвешивания = ЗапросПривес.Выполнить().Выгрузить();
    ПривесСтр = 0;
    Если ВвестиЧисло (ПривесСтр, "Введите привес", 15, 2) Тогда
    Для Каждого Строка Из Взвешивание Цикл
    Строка.Привес = ПривесСтр / КоличествоСтрок; ///? как правильно прописать эту строку она должна довать результат деления и выводить в каждую строку привес.(500 / количество строка Привес )= результат в каждую строку Привес
    Строка.Масса = Строка.МассаПред + Строка.Привес;
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры
  2. Muggsy
    Offline

    Muggsy одно ЭС

    Регистрация:
    10 сен 2008
    Сообщения:
    243
    Симпатии:
    0
    Баллы:
    26
    Если КоличествоСтрок = 0 Тогда
    о (или другое значение)
    Иначе
    Строка.Привес = ПривесСтр / КоличествоСтрок;
    КонецЕсли
    Еще желательно в таблице значений объявить колонку привес, создать в запросе со значением 0(или другим):
    | КА_МассаСкота.Масса как Масса, 0 как Привес
    |ИЗ
    | РегистрСведений.КА_МассаСкота КАК КА_МассаСкота
    Или я что-то неправильно поняла?
  3. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Спасибо что откликнулись на вопрос, но я уже сделал...
    Процедура РаспределитьПривес(Кнопка)
    ПерезаполнитьПредыдущийВесИПривесы();
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ
    | КА_МассаСкота.Скот
    |ИЗ
    | РегистрСведений.КА_МассаСкота КАК КА_МассаСкота";
    Привес=Взвешивание.ВыгрузитьКолонки("Привес");
    Запрос.УстановитьПараметр("Привес", Привес);
    ТабВзвешивания = Запрос.Выполнить().Выгрузить();
    ПривесСтр = 0;
    Если ВвестиЧисло (ПривесСтр, "Введите привес", 15, 2) Тогда
    Для Каждого Строка Из Взвешивание Цикл
    Строка.Привес = ПривесСтр / Взвешивание.Количество();
    Строка.Масса = Строка.МассаПред + Строка.Привес;
    КонецЦикла;
    КонецЕсли;


    КонецПроцедуры
  4. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Подскажите как в запросе ДатуСмерти сравнить с концом периода?

Поделиться этой страницей