8.х Создать документ реализации товара на основании оприходования товара в Бухгалтерии 3.0

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем SnakeSolid, 30 авг 2017.

  1. TopicStarter Overlay
    SnakeSolid
    Offline

    SnakeSolid

    Регистрация:
    2 май 2013
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    1С Бухгалтерия 8.3 типовая, платформа 8.3.9.1818

    Здравствуйте уважаемые форумчане.
    Поставили задачу: "на основании оприходования создать документ реализации, чтобы не подтягивать номенклатуру путем поиска и подбора". Конфа типовая и трогать запрещено, так что только внешней обработкой приходится обходиться.

    Погуглив и пораскинув мозгами у меня, на данный момент, получилась такая вот вещь:
    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
    
        ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.25");
     
        ПараметрыРегистрации.Назначение.Добавить("Документ.ОприходованиеТоваров");
     
        ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиСозданиеСвязанныхОбъектов();
     
        ПараметрыРегистрации.Вставить("Наименование", "Реализация товара");
        ПараметрыРегистрации.Вставить("Версия", "1.0");
        ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
        ПараметрыРегистрации.Вставить("Информация", "Создание документа реализации товара на основании оприходования деталей, высвободившихся после ремонта вагона");
     
        НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
        НоваяКоманда.Представление = "Реализация товара";
        НоваяКоманда.Идентификатор = "Реализация товара";
        НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовКлиентскогоМетода();
        НоваяКоманда.ПоказыватьОповещение = Истина;
     
        Возврат ПараметрыРегистрации;
     
    КонецФункции
    
    
    &НаКлиенте
    Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, СозданныеОбъекты) Экспорт
    
        Для каждого Элемент из ОбъектыНазначения Цикл
    
            ФормаДок = ПолучитьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта");
         
            ДанныеФормы = ФормаДок.Объект;
    
            СоздатьНовыйДокумент(Элемент, ДанныеФормы);
         
            КопироватьДанныеФормы(ДанныеФормы, ФормаДок.Объект);
    
            ФормаДок.Открыть();
        КонецЦикла;
    
    КонецПроцедуры
    
    &НаСервере
    Процедура СоздатьНовыйДокумент(Элемент, НовыйОбъект)
    
        Основание = Элемент.Ссылка;
    
        НовыйОбъект.Дата = ТекущаяДата();
        НовыйОбъект.Товары = Основание.Товары;
    
        Для каждого СтрокаТЧ из Основание.Товары Цикл
         
            НоваяСтрока = НовыйОбъект.Товары.Добавить();
            НоваяСтрока.Номенклатура = СтрокаТЧ.Номенклатура;
            НоваяСтрока.Количество = СтрокаТЧ.Количество;
            НоваяСтрока.Цена = СтрокаТЧ.Цена;
     
         
        КонецЦикла;
     
        НовыйОбъект.Товары.Сумма = НовыйОбъект.Товары.Сумма;
     
        Элемент.Записать(РежимЗаписиДокумента.Запись);
     
    КонецПроцедуры
    
    Но при запуске обработки мне выдается все равно ошибка
    ошибка.jpg

    Ссылается на "Общий модуль ДополнительныеОтчетыИОбработкиКлиент" :
    Код:
    ФормаОбработки.ВыполнитьКоманду(ВыполняемаяКоманда.Идентификатор, ОбъектыНазначения, СозданныеОбъекты);
    Подскажите, что не так делаю и в чем проблема? Весь инет облазил - обсуждают только аналогичные обработки только для УТ, а у меня Бухгалтерия. Неужели в Бухгалтерии это вообще не работает?

    Всем заранее спасибо.
    Последнее редактирование: 31 авг 2017

Поделиться этой страницей