8.х Создание внешней обработки для загрузки текстового файла

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Ajlma3uk, 11 апр 2014.

  1. TopicStarter Overlay
    Ajlma3uk
    Offline

    Ajlma3uk

    Регистрация:
    11 апр 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Пожалуйста выручайте,никак не получается сделать.пробовала и так и сяк уже
    Задание:
    1.На форме должно быть поле для выбора текстового файла ;

    2.Второе тестовое поле для загрузки выбранного из файла;

    3.Сама кнопка загрузки при нажатии на кнопку происходит загрузка содержимого из файла и если файл не текстовый то вывести сообщение об ошибке

    1 пункт у меня получился-сделала в с помощью ДиалогаВыбора, не получается загрузить содержимое файла во 2 текстовое поле
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Может вашу просьбу перекинуть в другую ветку, например для фрилансеров ???
  3. TopicStarter Overlay
    Ajlma3uk
    Offline

    Ajlma3uk

    Регистрация:
    11 апр 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    почему?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вы надеетесь на бесплатную помощь ?
    --- Объединение сообщений, 11 апр 2014 ---
    Там по сути долов на 10 минут. Ну может найдутся интузиасты.
  5. TopicStarter Overlay
    Ajlma3uk
    Offline

    Ajlma3uk

    Регистрация:
    11 апр 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    хорошо.просто новичок в этом деле и никак не получается сделать
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Тогда почитайте в синтаксис-помщнике про ТекстовыйДокумент.
    --- Объединение сообщений, 11 апр 2014 ---
    По сути, ваша проблема решается одной строчкой кода:
    Код:
    ТекстДок.Прочитать("catalog.txt");
  7. TopicStarter Overlay
    Ajlma3uk
    Offline

    Ajlma3uk

    Регистрация:
    11 апр 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПолеВвода1НачалоВыбора(Элемент, СтандартнаяОбработка)
     Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
     Диалог.Заголовок = "Выберите файл";
     Диалог.МножественныйВыбор=Ложь;
     Диалог.Фильтр = "Текстовый файл (*.txt)|*.txt"; 
     Диалог.ПредварительныйПросмотр = Истина;
     Если Диалог.Выбрать() Тогда
     Выбор=Диалог.ПолноеИмяФайла;
     КонецЕсли;   
    КонецПроцедуры
    Пока вот только такой код

    Вложения:

    • 1.png
      1.png
      Размер файла:
      6,2 КБ
      Просмотров:
      6
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    В чем сложность ? Выбираете файл, далее обрабатываете его в обработчиках, либо вешаете кнопку обработки, и там уже обрабатываете.
    Неужели сложно написать:
    Код:
    ВашеТекстовоеПоле.Прочитать("АдресФайлаИзВашегоПоля");
  9. TopicStarter Overlay
    Ajlma3uk
    Offline

    Ajlma3uk

    Регистрация:
    11 апр 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Для человека который этим занимается неделю-да,мне сложно
  10. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    это можно за пару вечеров осилить
    на форму вы ложите поле ввода (где будете выбирать файл и его местоположение)
    в событие "НачалоВыбора" этого поля пишете примерно такой код
    Код:
    &НаКлиенте
    Процедура НужныйФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
            ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
            ДиалогОткрытияФайла.Фильтр             = "Файл  (*.txt)|*.txt";
            ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
            ДиалогОткрытияФайла.Заголовок = НСтр("ru = 'Выберите путь к файлу данных'");
            Если ДиалогОткрытияФайла.Выбрать() Тогда
                ФайлДанных = ДиалогОткрытияФайла.ПолноеИмяФайла;
            КонецЕсли;
    КонецПроцедуры
    
    в коде обработки кнопки/команды
    пишете код свой
    Код:
    &НаКлиенте
    Процедура Выполнить(Команда)
        ЗагрузитьНужныйФайл();
    КонецПроцедуры
    
    Код:
    &НаСервере
    Функция ЗагрузитьНужныйФайлПродаж()
         
        ФайлНужныхДанных = Новый ТекстовыйДокумент;
        ФайлНужныхДанных.Прочитать(ФайлДанных);
    //......... пишите нужный ещё код..............
    КонецПроцедуры
    
  11. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    у вас приложение обычное или управляемое?

Поделиться этой страницей