8.х Создание темы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Сергей1111, 27 июл 2016.

?

В чем моя ошибка

  1. Прописать превес

    0 голосов
    0,0%
  2. Вывод результата

    0 голосов
    0,0%
  1. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    В ведомости ВзвешиваниеЖивотных создал кнопку "ВвестиПривес", она далжна осуществлять действие при нажатие на кнопку перед пользователем должна высвечиваться окно с запросов "введите привес" после ввода определенного числа пользователем программа должна заполнить привес по всем позициям животных в ТЗ Взвешивание.
    Вот попробовал
    Процедура ВвестиПривес(Кнопка)
    Взвешивание.Очистить.Колонку("Привес");
    Привес = 0;
    Если ВвестиЧисло(Привес, "Введите привес", 15, 3) Тогда
    ПривесСтроки = Привес / Привес.Взвешивание.Количество();
    Для Каждого Строка Из Привес.Взвешивание Цикл
    Строка.Привес = ПривесСтроки;
    КонецЦикла;
    КонецЕсли;
    ПерезаполнитьПредыдущийВесИПривесы();
    КонецПроцедуры

    Ругается на
    {Документ.КА_ВедомостьВзвешиванияЖивотных.Форма.ФормаДокумента.Форма(72)}: Значение не является значением объектного типа (Взвешивание)
    ПривесСтроки = Привес / Привес.Взвешивание.Количество();
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Вы уж определитесь:
    Либо Привес = 0;
    Либо Привес.Взвешивание.Количество();
  3. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Как правильно прописать?
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Не именовать одинаково переменные/реквизиты/ТЧ
  5. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    привес называю дельта. менял везде ругается все равно
    --- Объединение сообщений, 27 июл 2016 ---
    Процедура ВвестиПривес(Кнопка)

    Дельта = 0;
    Если ВвестиЧисло(Дельта, "Введите привес", 15, 3) Тогда
    ПривесСтроки = Дельта / Взвешивание.Привес.Количество();
    Для Каждого Строка Из Взвешивание.Привес Цикл

    КонецЦикла;
    КонецЕсли;
    ПерезаполнитьПредыдущийВесИПривесы();
    КонецПроцедуры

    {Документ.КА_ВедомостьВзвешиванияЖивотных.Форма.ФормаДокумента.Форма(73)}: Поле объекта не обнаружено (Привес)
    ПривесСтроки = Дельта / Взвешивание.Привес.Количество();
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Вы прикалываетесь?

    Изначально было:

    Привес.Взвешивание.Количество();

    Стало:

    Взвешивание.Привес.Количество();
  7. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Извини, я не прикалываюсь, просто не понимаю. Покажи как сделать нужно если не затруднит.
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Я не знаю, что вы там уже наделали.
    Взвешивание.Привес.Количество() - вот эта конструкция вообще не понятна. Какой тип значения у Взвешивание?
  9. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Взвешивание это название табличной части
    --- Объединение сообщений, 27 июл 2016 ---
    Задача что бы при вводе числа в таб.части Взвешивание в колонке привес по всем коровам про ставилось именно то число которое ввел пользователь.
    Голову ломаю не знаю как сделать...
  10. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    тогда не понятно "... Из Взвешивание.Привес Цикл" :)
    --- Объединение сообщений, 27 июл 2016 ---
    Надо было бы начать с 1. Указания платформы, 2 Указания конфигурации
    --- Объединение сообщений, 27 июл 2016 ---
    3. Для конкретики, какую форму правите, "Управляемую", или "обычную"
  11. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Вы с программированием вообще и 1С, в частности, насколько знакомы?
  12. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    в "голосовалке" ошибка, конкретно в слове "превес"
  13. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    плохо знаком. Изучаю самостоятельно. Многое не поддается.




    Процедура ЗаполнитьПоУчетнойГруппеЗаполнитьПоУчетнойГруппе(Кнопка)
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("Перед заполнением табличная часть будет очищена. Продолжить? ", Режим, 0);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
    Возврат;
    КонецЕсли;
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("ДатаДокумента", ТекущаяДата());
    Запрос.УстановитьПараметр("ВозрастС", СтатусКРС.ВозрастС);
    Запрос.УстановитьПараметр("ВозрастПо", СтатусКРС.ВозрастПо);
    Запрос.УстановитьПараметр("ПолЖивотного", СтатусКРС.ПолЖивотного);
    Запрос.Текст = "ВЫБРАТЬ
    | КА_Скот.Ссылка
    |ИЗ
    | Справочник.КА_Скот КАК КА_Скот
    |ГДЕ
    | РАЗНОСТЬДАТ(КА_Скот.ДатаРождения, &ДатаДокумента, МЕСЯЦ) >= &ВозрастС
    | И РАЗНОСТЬДАТ(КА_Скот.ДатаРождения, &ДатаДокумента, МЕСЯЦ) < &ВозрастПо
    | И КА_Скот.ПолЖивотного = &ПолЖивотного";



    Результат=Запрос.Выполнить();
    ТЗ = Результат.Выгрузить();
    ТЗ = Запрос.Выполнить().Выгрузить();
    Взвешивание.Очистить();
    Для Каждого Стр Из ТЗ Цикл
    НоваяСтр = Взвешивание.Добавить();
    НоваяСтр.Скот=Стр.Ссылка;
    КонецЦикла;
    ПерезаполнитьПредыдущийВесИПривесы();

    КонецПроцедуры


    это первая каманда которую создал, она работает.
    --- Объединение сообщений, 27 июл 2016 ---
    Что не так там прописал?
    --- Объединение сообщений, 27 июл 2016 ---
    В выхожу из конструктора, открываю документ кнопка отвечает. Открывается окно ввода, жму на ок. ругается!

    {Документ.КА_ВедомостьВзвешиванияЖивотных.Форма.ФормаДокумента.Форма(73)}: Поле объекта не обнаружено (Привес)
    ПривесСтроки = Взвешивание.Привес.Дельта();
    Последнее редактирование: 27 июл 2016
  14. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Читайте синтаксис-помощник, много вопросов должны найти ответы.

    Если у вас Взвешивание - это табличная часть/ТЧ, то и получайте количество от нее, не нужно указывать имя колонки при этом.

    P.S. Почитайте книги по основам программирования 1С. Взять программирование измором не получится.
    Последнее редактирование: 27 июл 2016
  15. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Извините пожалуйста,но не нашел я ответ. Еще не научился правильно пользоваться синтекс-помощником....
  16. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Вы не ответили, с чем вы работаете !
  17. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
  18. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    дальше, конфигурация какая ?
  19. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    1с управление сельскохозяйственным предприятием, редакция 1.3
  20. TopicStarter Overlay
    Сергей1111
    Offline

    Сергей1111

    Регистрация:
    27 июл 2016
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Подскажите, правда не знаю как делать...
Похожие темы
  1. mialord
    Ответов:
    9
    Просмотров:
    1.316
  2. Тимон
    Ответов:
    8
    Просмотров:
    1.130
Загрузка...

Поделиться этой страницей