8.х Создание списка из значений перечислений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Vi85, 14 мар 2008.

  1. TopicStarter Overlay
    Vi85
    Offline

    Vi85

    Регистрация:
    18 фев 2008
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Как создать список из перечислений? У меня открывается только название перечисления(виды событий), а не его значения(письмо, е-маil, встреча)
    Вот код:

    Код:
    Переч = Метаданные.Перечисления;
    СписокПеречислений = Новый СписокЗначений();
    СписокПеречислений.Добавить(Переч.ВидыСобытий,,Ложь);
    Если СписокПеречислений.ОтметитьЭлементы("Выбрать событие") Тогда
    
    Для каждого НазваниеДокумента Из СписокПеречислений Цикл
    
    Если НазваниеДокумента.Пометка Тогда
    
    ФормаСписка = Метаданные.Документы.Событие.ПолучитьФормуСписка();
    ФормаСписка.Открыть();
    
    КонецЕсли; 
    
    КонецЦикла; 
    
    КонецЕсли;
    
  2. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    А просто в цикле занчения перечислений, а не его само присвоить в список значений не пойдет?
  3. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Код:
    СписокЗначений = Новый СписокЗначений;
    Для Каждого ЗначениеПеречисления Из Перечисления.ИМЯПЕРЕЧИСЛЕНИЯ Цикл
    СписокЗначений.Добавить(ЗначениеПеречисления, , Ложь);
    КонецЦикла;
    
    
  4. TopicStarter Overlay
    Vi85
    Offline

    Vi85

    Регистрация:
    18 фев 2008
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Этот код не дает форму выбора. 1С его просто хавает, не ругаясь и ничего не делает.

    Я вот такой код пытаюсь реанимировать:

    С
    Код:
    писокВыбора = Новый СписокЗначений;
    Для КАЖДОГО ВидСобытия ИЗ Перечисления.ВидыСобытий Цикл
    
    ЭлементСписка = СписокВыбора.Добавить(ВидСобытия, ,Ложь);
    Для каждого ЭлементСписка Из СписокВыбора Цикл
    
    Если ЭлементСписка.Пометка Тогда
    
    ФормаСпискаДокумента = Метаданные.Документы.Событие.ОсновнаяФормаСписка;
    ФормаСпискаДокумента.Открыть();
    
    КонецЕсли; 
    
    КонецЦикла; 
    
    КонецЦикла;
    
    Уважаемый, не первый день же на форуме - тэг
    Код:
     надо уже научиться уже использовать[/color]
  5. TopicStarter Overlay
    Vi85
    Offline

    Vi85

    Регистрация:
    18 фев 2008
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Небольшое изменение в коде и все получилось.

Поделиться этой страницей