8.х Создание подобия чата в конфе.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Jaivan, 7 май 2007.

  1. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Всем Привет!
    Необходимо реализовать переписку пользователей по документам, с которыми они работают, учитывая права на их просмотр, на основе признаков прочтения, выполнения и события данного документа.
    Помогите, кто чем может....
  2. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Напиши сою аську мне в личку, я тебе скину аську для восьмерки!
  3. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    у меня только майл агент есть, заведу - сообщу, а чего за аська такая, специальная что ли?
  4. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26

    Ну типо того, для восьмерки! Хорошая вешь!
  5. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Если не сложно закинь мне ее на мыло: vanezzz@list.ru, я на работе сижу мне как раз это задание надо бы доделать побысрей, хотя бы план реализации предоставить.
  6. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Вообще аську уже скачал, только как ее подключить не понимаю нашел какой то код:
    Инициализация компоненты:

    ИмяВК="AddIn.DushelovICQ";

    Попытка
    ПодключитьВнешнююКомпоненту(ИмяВК);
    Исключение
    Предупреждение("Не удалось подключить компоненту "+ИмяВК);
    КонецПопытки;

    Попытка
    icq = Новый(ИмяВК);
    Исключение
    Предупреждение("Ошибка создания объекта внешней компоненты: "+ ИмяВК);
    КонецПопытки;

    ---
    Обработка внешнего события:

    Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Если Источник = "DushelovICQ" Тогда
    Если Событие = "Сообщение" Тогда
    //Данные - текст входящего сообщения
    Иначе
    //Данные - текст состояние-сообщения
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры

    ---
    Соединиться с сервером:

    icq.Сервер = Сервер;
    icq.НомерICQ = НомерICQ;
    icq.Пароль = Пароль;
    icq.Соединиться();

    ---
    Отсоединиться от сервера:

    icq.Отсоединиться();

    ---
    Отослать сообщение:

    icq.НомерICQАдресата = НомерICQПользователя;
    icq.Сообщение = ТекстСообщения;
    icq.ОтослатьСообщение();

    Куда его конкретно вписать надо? Как придти к главному итогу: сотрудники на предприятии переписываются между собой, с учетом настройки видимости сообщения?
  7. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Помогите кто чем может, горю! :unsure:
    Как все же все это подключить?
    Куда код вписать?
    Где нужно саму библиотеку разместить?
    Где она потом в режиме Предприятия должна появиться?
  8. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Скинул тебе аську на мыло, 2 разновидности, читай ридми там все написано! Кстати, будешь объединять конфиги, незабудь галку убрать со свойств основной конфы, а то жо..а будет! И сделай предварительную копию базы!
  9. Goth
    Offline

    Goth

    Регистрация:
    4 апр 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
  10. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26

    Выложил на фолдер, качайте там! Вот ссылка http://ifolder.ru/1943625
  11. ilqar93
    Offline

    ilqar93

    Регистрация:
    8 май 2007
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Я в 1С новичок, но мне интересно -нельзя чат сделать с помощью MSMQ (messaging queue)?

    :unsure:
  12. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    to B@girusss

    спасибо за архив!

Поделиться этой страницей