7.7 Создание печатной формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем red14_88, 22 янв 2011.

  1. TopicStarter Overlay
    red14_88
    Offline

    red14_88

    Регистрация:
    22 янв 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Платформа 1С Предприятие 7.70.027
    конфа Комплексная 7.70.501

    Задача - получить печатную форму документа "Реализация", содержащую таблицу, состоящую из Номенклатуры, ее количества, и "сертификата". Где "Сертификат" это дополнительный реквизит в табличной части документа ПоступлениеТМЦРозница. Сертификат - это элемент справочника сертификатов, содержащего всего 3 текстовых поля и одно поле Дата.

    Собственно проблема в получении и выгрузке данных в печатную форму, раньше работал только с восьмёркой.

    Что нашёл: в строке как приходного, так и расходного документов, есть реквизит "Партия" одного и того же типа.

    Вопросы:
    1.как составить запрос, вытаскивающий нужные мне данные?
    2.как эти данные из запроса выгрузить в печатную форму (саму форму создал в виде отдельного файла, задал секции шапки и строки, определил ячейки-переменные)?

    Заранее всем спасибо.
  2. TopicStarter Overlay
    red14_88
    Offline

    red14_88

    Регистрация:
    22 янв 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Вопрос №2 снят. Вопрос №1 режет душу. Хочется доделать и хоть один выходной отдохнуть
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Реквизит справочника партии (из расходной) содержит ссылку на документ поступления (в котором сертификат). Но не все так просто поскольку у вас наверняка автораспределение партий товара. И если один и тот же товар приходит от разных поставщиков... все будет зависить от метода списания (фифо/лифо/средней) которые установлены у фирмы
  4. TopicStarter Overlay
    red14_88
    Offline

    red14_88

    Регистрация:
    22 янв 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Вопрос решён, всем спасибо
    Код:
    НПП = 0;               
    Рег=СоздатьОбъект("Регистр.ПартииНаличие");
    Если Рег.ВыбратьДвиженияДокумента(ТекущийДокумент())=1 Тогда
    Пока Рег.ПолучитьДвижение()=1 Цикл
    УПартия = Рег.Партия;
    УНоменклатура = Рег.Номенклатура;
    ПриходныйДокумент = (Рег.Партия.ПриходныйДокумент);
    ПриходныйДокумент.ВыбратьСтроки();
    Пока ПриходныйДокумент.ПолучитьСтроку() = 1 Цикл
    Если ПриходныйДокумент.Номенклатура = УНоменклатура Тогда
    НПП = НПП +1;
    Сертификат = ПриходныйДокумент.Сертификат;
    ПечТабл.ВывестиСекцию("Строка");                          
    КонецЕсли;
    КонецЦикла;//Получить строку приходного документа
    КонецЦикла;//Движения расходного документа
    КонецЕсли;
    
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А как в данном алгоритме учитывать если на 1 позицию товара 2-3 позиции в поступлении (разные сертификаты) + есть еще такая пакостная вещь как "не распределение по партиям" (когда нарушена последовательность). В документе товар есть и с остатков списан. А в партиях нет

Поделиться этой страницей