8.х Создание папок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем igorekkrav, 4 апр 2011.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Добрый день! Появилась проблема следующего характера. При создании папки в (Статьи движения денежных средств) Конфиг УТ. Выдает ошибку

    {Справочник.СтатьиДвиженияДенежныхСредств(4)}: Преобразование значения к типу Булево не может быть выполнено


    В чем может быть причина
  2. Неназываемый
    Offline

    Неназываемый Опытный в 1С Команда форума

    Регистрация:
    2 фев 2007
    Сообщения:
    507
    Симпатии:
    7
    Баллы:
    29
    Какой такой папки?
    Этот справочник не иерархический.
  3. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Хмм . Есть база такая же там созданы папки и статьи по ним разложены. А тут просто списком и не дает создать папку. Посмотрел в конфигураторе. Он иерархический.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    М.б. в той папке созданы уровни... Проверяйте текущую ИБ на наличие групп
  5. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Знать бы где проверить. Самое интересное в изначальной ИБ все ок. А после сохранении конфигурации и создания новой ИБ в ней перестало работать.
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Разве? УТ под рукой сейчас нет, но вроде как очень даже иерархический с неограниченным уровнем иерархии.

    Игорь Крав конфигурация типовая или дописывали?
  7. Неназываемый
    Offline

    Неназываемый Опытный в 1С Команда форума

    Регистрация:
    2 фев 2007
    Сообщения:
    507
    Симпатии:
    7
    Баллы:
    29
    Проверял на последней 10-ке. В типовой, нет иерархии.
  8. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    А реквизиты такие и должны быть в справочнике этом (mamvОтражатьВФР , mamvВыплатаЗП , mamvАренда) И значение булево!?

    "Управление торговлей", редакция 10.3 (10.3.8.9)
    Возможно она уже не типовая . На сколько изменили не могу сказать. Но стоит иерархия.
  9. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Хм. Странно. Тогда ваша правда.

    Не должны. Смотрите ваш код.
  10. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Посмотрел да в типов нет иерархии. А в исправленной у меня есть:(

    Исправленная конфа . Не понятно почему в сохраненой конфигурации отказывается работать

    Посмотрел конфа исправленная . Не понятно почему в сохраненной конфигурации не работает .
  11. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Я нашел в чем причина . Но не пойму почему так . Конфа действительно не типовая . Иерархию можно делать. Есть 2 реквизита и модуль документа

    Процедура ПередЗаписью(Отказ)

    Если mamvАренда И
    mamvВыплатаЗП Тогда
    Сообщить("Одновременно установлены признаки аренды и выплаты ЗП", СтатусСообщения.Внимание);
    Отказ = Истина;
    КонецЕсли;

    КонецПроцедуры

    Если его включаешь пишет ошибку при создании папки

    {Справочник.СтатьиДвиженияДенежныхСредств(4)}: Преобразование значения к типу Булево не может быть выполнено

    Есть отключаешь нормально создает папку!
    Не кто не знает почему может так быть?
  12. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Реквизиты mamvАренда и mamvВыплатаЗП какой тип имеют?

    Отладчиком пройдитесь, на момент исполнения значения этих реквизитов чему равны?
  13. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Потому что ваши добавленные реквизиты используются только для элемента справочника, а для группы - нет. Добавьте там проверку на группу.
    Код:
    Если Не ЭтоГруппа Тогда
    Если mamvАренда И
    mamvВыплатаЗП Тогда
    Сообщить("Одновременно установлены признаки аренды и выплаты ЗП", СтатусСообщения.Внимание);
    Отказ = Истина;
    КонецЕсли;
    КонецЕсли;
    
  14. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    СПАСИБО!!! Все заработало! :angry:

    Это значения булево! Разобрался не работало при создании папки потому что это группа .

Поделиться этой страницей