8.х создание отчеа в УАТ ПП

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kurg75, 25 апр 2011.

  1. TopicStarter Overlay
    kurg75
    Offline

    kurg75

    Регистрация:
    24 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Люди!!
    Памажите кто чем может начинающему.
    На пердпрятии используется УАТ ПП редакция 3
    возникла нобходимость формирования отчета с выборкой данных из путевых листов
    в разрезе по водителям за период времени
    из путевых листов необходимо выбрать пробег ТС порожний (без груза), километраж заказа ести таковой был

    подскажите как правильно создать запрос в конструкторе запросов

    если до чего дойду сам результаты выложу
  2. Oleg_NSK
    Offline

    Oleg_NSK Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    164
    Симпатии:
    0
    Баллы:
    26
    Берем конструктор запросов и действуем :angry:
  3. TopicStarter Overlay
    kurg75
    Offline

    kurg75

    Регистрация:
    24 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    был создан отчет при отладке выдает сообщение об ошибке


    {Отчет.СводЗаказ.Форма.Заказ(36,36)}: Переменная не определена (НачПериода)
    НастройкаПериода.УстановитьПериод(<<?>>НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    {Отчет.СводЗаказ.Форма.Заказ(36,50)}: Переменная не определена (КонПериода)
    НастройкаПериода.УстановитьПериод(НачПериода, ?(<<?>>КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    {Отчет.СводЗаказ.Форма.Заказ(36,75)}: Переменная не определена (КонПериода)
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', <<?>>КонПериода, КонецДня(КонПериода)));
    {Отчет.СводЗаказ.Форма.Заказ(36,96)}: Переменная не определена (КонПериода)
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(<<?>>КонПериода)));

    ГДЕ и ЧТО я делаю не так ??????????????????




    Код:
    
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    ЗаказИнициализация();
    
    КонецПроцедуры
    
    Процедура ПриЗакрытии()
    
    СохранитьЗначение("НастройкаОтчетыСводЗаказЗаказ_122effa1-0651-4555-9e84-c5b022c394ff", ПостроительОтчетаЗаказ.ПолучитьНастройки());
    
    КонецПроцедуры
    
    
    
    
    
    Процедура ВыбПериодНажатие(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.УстановитьПериод((НачПериода='0001-01-01', НачПериода, НачалоДня(НачПериода)), ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    Если НастройкаПериода.Редактировать() Тогда
    НачПериода = НастройкаПериода.ПолучитьДатуНачала();
    КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
    КонецЕсли;
    КонецПроцедуры
    
    
    
    
    
    Процедура ВыбПериодНажатие1(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    Если НастройкаПериода.Редактировать() Тогда
    НачПериода = НастройкаПериода.ПолучитьДатуНачала();
    КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
    КонецЕсли;
    КонецПроцедуры
    
    Процедура ДействияФормыЗаказНастройка(Кнопка)
    //{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_НАСТРОЙКА(Заказ)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Форма = ОтчетОбъект.ПолучитьФорму("ЗаказНастройка");
    Форма.ПостроительОтчета = ПостроительОтчетаЗаказ;
    Настройка = ПостроительОтчетаЗаказ.ПолучитьНастройки();
    Если Форма.ОткрытьМодально() = Истина Тогда
    ЗаказВывести();
    Иначе
    ПостроительОтчетаЗаказ.УстановитьНастройки(Настройка);
    КонецЕсли;
    
    //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_НАСТРОЙКА
    КонецПроцедуры
    
    Процедура ДействияФормыЗаказСформировать(Кнопка)
    //{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПРОЦЕДУРА_ВЫЗОВА(Заказ)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    ЗаказВывести();
    
    //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПРОЦЕДУРА_ВЫЗОВА
    КонецПроцедуры
    
    Процедура ЗаказВывести()
    //{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_ВЫПОЛНИТЬ(Заказ)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    ЭлементыФормы.ПолеТабличногоДокумента.Очистить();
    
    ПостроительОтчетаЗаказ.Выполнить();
    ПостроительОтчетаЗаказ.РазмещениеИзмеренийВСтроках = ТипРазмещенияИзмерений.Вместе;
    ПостроительОтчетаЗаказ.РазмещениеРеквизитовИзмеренийВСтроках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
    ПостроительОтчетаЗаказ.РазмещениеРеквизитовИзмеренийВКолонках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
    ПостроительОтчетаЗаказ.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Классика);
    ПостроительОтчетаЗаказ.Вывести(ЭлементыФормы.ПолеТабличногоДокумента);
    
    //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_ВЫПОЛНИТЬ
    КонецПроцедуры
    
    Процедура ЗаказИнициализация()
    //{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_ИНИЦИАЛИЗАЦИЯ(Заказ)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    ПостроительОтчетаЗаказ.Текст =
    "ВЫБРАТЬ
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Дата КАК Дата,
    |	уатПутевойЛистЗаказыМУПА.Ссылка.ТранспортноеСредство КАК ТранспортноеСредство,
    |	ПРЕДСТАВЛЕНИЕ(уатПутевойЛистЗаказыМУПА.Ссылка.ТранспортноеСредство),
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Водитель1 КАК Водитель1,
    |	ПРЕДСТАВЛЕНИЕ(уатПутевойЛистЗаказыМУПА.Ссылка.Водитель1),
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Водитель2 КАК Водитель2,
    |	ПРЕДСТАВЛЕНИЕ(уатПутевойЛистЗаказыМУПА.Ссылка.Водитель2),
    |	уатПутевойЛистЗаказыМУПА.ВремяВЗаказе,
    |	уатПутевойЛистЗаказыМУПА.РасстояниеЗаказа,
    |	СУММА(уатПутевойЛистЗаказыМУПА.СуммаЗаказа) КАК СуммаЗаказа
    |ИЗ
    |	Документ.уатПутевойЛист.ЗаказыМУПА КАК уатПутевойЛистЗаказыМУПА,
    |	РегистрНакопления.уатЗаказыНаТС КАК уатЗаказыНаТС
    |
    |СГРУППИРОВАТЬ ПО
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Дата,
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Водитель1,
    |	уатПутевойЛистЗаказыМУПА.Ссылка.Водитель2,
    |	уатПутевойЛистЗаказыМУПА.ВремяВЗаказе,
    |	уатПутевойЛистЗаказыМУПА.РасстояниеЗаказа,
    |	уатПутевойЛистЗаказыМУПА.Ссылка.ТранспортноеСредство
    |
    |УПОРЯДОЧИТЬ ПО
    |	Дата,
    |	ТранспортноеСредство,
    |	Водитель1,
    |	Водитель2
    |АВТОУПОРЯДОЧИВАНИЕ";
    ПостроительОтчетаЗаказ.ЗаполнитьНастройки();
    ПостроительОтчетаЗаказ.ЗаполнениеРасшифровки = ВидЗаполненияРасшифровкиПостроителяОтчета.ЗначенияГруппировок;
    ПостроительОтчетаЗаказ.ТекстЗаголовка = "Заказ";
    Настройка = ВосстановитьЗначение("НастройкаОтчетыСводЗаказЗаказ_122effa1-0651-4555-9e84-c5b022c394ff");
    Если Настройка <> Неопределено Тогда
    ПостроительОтчетаЗаказ.УстановитьНастройки(Настройка);
    КонецЕсли;
    
    //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ_ПОСТРОИТЕЛЬОТЧЕТА_ИНИЦИАЛИЗАЦИЯ
    КонецПроцедуры
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    

Поделиться этой страницей