8.х Создание обработчика в УТ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Rishat1c, 18 авг 2016.

  1. TopicStarter Overlay
    Rishat1c
    Offline

    Rishat1c

    Регистрация:
    18 авг 2016
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Всем доброго дня суток, есть обработчик (в обработчике цикл) который закрывает документы (заказы).
    НО есть маленькая проблема, как только встречается документ где номенклатура не заполнена (или что нибудь в этом роде) , то цикл обрывается [​IMG]

    // Начало цикла
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Объект = ВыборкаДетальныеЗаписи.ЗаказКлиента.ПолучитьОбъект();
    КоличествоОтмененныхСтрок = ПродажиСервер.ОтменитьНепоставленныеСтроки(Объект, "Товары", ПричинаОтмены, Истина);
    Если КоличествоОтмененныхСтрок>0 Тогда
    Объект.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
    КонецЦикла;
    // Конец цикла


    Помогите состряпать проверку или исключение как решить/обойти эту проблему
    Буду рад услышать любые варианты решения
    Спасибо за внимание!
  2. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    Вариантов много: Самый примитивный:
    Код:
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
       Объект = ВыборкаДетальныеЗаписи.ЗаказКлиента.ПолучитьОбъект();
       Попытка
          КоличествоОтмененныхСтрок = ПродажиСервер.ОтменитьНепоставленныеСтроки(Объект, "Товары", ПричинаОтмены, Истина);
          Если КоличествоОтмененныхСтрок>0 Тогда
             Объект.Записать(РежимЗаписиДокумента.Проведение);
          КонецЕсли;
       Исключение
         
       КонецПопытки;
    КонецЦикла;
    
    
    --- Объединение сообщений, 19 авг 2016 ---
    [​IMG]

Поделиться этой страницей