8.х Создание/корректировка текстового файла регламентным заданием на сервере

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Stack_G, 23 окт 2009.

  1. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Решил автоматизировать удаление помеченных объектов с сохранением ссылочной целостности через регламентное задание. Клиент-сервер.
    Сделал, все здорово. "Свободные" объекты удаляются.
    Дальше задался целью вести лог-файл.
    Вот тут то и ступор.
    Код:
    ПомеченныеОбъекты = НайтиПомеченныеНаУдаление();
    Если ПомеченныеОбъекты.Количество() > 0 Тогда
    УстановитьМонопольныйРежим(Истина);
    Файл = "D:\arhiv\del_log.txt";
    ТД = Новый ТекстовыйДокумент;
    ТД.ДобавитьСтроку("Удаление помеченных объектов.");
    ТД.ДобавитьСтроку( "Начало " + ТекущаяДата());
    ТД.ДобавитьСтроку("-> Помечены на удаление:");
    Для каждого Элемент Из ПомеченныеОбъекты Цикл
    ТД.ДобавитьСтроку(СокрЛП(Элемент));
    КонецЦикла;
    Найденные = Новый ТаблицаЗначений;
    УдалитьОбъекты(ПомеченныеОбъекты, Истина, Найденные);
    Если Найденные.Количество() > 0 Тогда
    Найденные.Свернуть("Ссылка");
    ТД.ДобавитьСтроку("-> Не удалось удалить:");
    Для каждого Ссылка Из Найденные Цикл
    ТД.ДобавитьСтроку (СокрЛП(Ссылка[0]));
    КонецЦикла;
    КонецЕсли;
    ТД.ДобавитьСтроку("Окончание " + ТекущаяДата());
    ТД.ДобавитьСтроку("===========================================================");
    ТД.Записать(Файл,"UTF-8");
    УстановитьМонопольныйРежим(ЛОЖЬ);
    КонецЕсли;
    
    Как видно, делал через табличный документ. Но!
    При запуске пользователем (внешняя обработка) все работает.
    При запуске регл. задания ошибка "Вывод запрещен".
    СП гласит: ТД.Прочитать() - недоступен на сервере 1С.
    Видимо и запись тож не дает по этой причине.
    Решил что через текстовый документ не получится... В раздумьях... Перед тем как использовать регистр сведений (там хранить логи, периодически удалять) решил посоветоваться.

    Может кто-нибудь решал подобную проблему? Как вывести информацию в текстовый файл методом регламентное задание на сервере?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    А что мешает сразу писать в текстовый документ?
  3. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    поясни, плиз :unsure:
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    Документ = Новый ТекстовыйДокумент;
    
  5. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    :) я ж так и делаю.
    Код:
    ТД = Новый ТекстовыйДокумент;
    
    как текстовый документ на жесткий записать-то?
    Код:
    ТД.Записать(Файл,"UTF-8");
    
    не пашет на сервере.
    в этом и вопрос заключается.

Поделиться этой страницей