8.х Создание и заполнение нового документа в 8.3

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем SpiritAT, 21 фев 2014.

  1. TopicStarter Overlay
    SpiritAT
    Offline

    SpiritAT Опытный в 1С

    Регистрация:
    8 авг 2013
    Сообщения:
    157
    Симпатии:
    0
    Баллы:
    26
    Создал журнал в наказание . хочу его заполнить из базы 1с 7.7. но он мне пишет Дата не может быть 0. хотя когда компилирую дата заполняется.

    Код:
    Процедура Загрузить_Журнал_Приказов_О_Наказании_в_ЗУП(Док)
         Сотр = НайтиСотрудника(Док.Сотрудник.Код, "", Док.ДатаДок);
         Если Сотр <> ""  Тогда
        Если Документы.ПриказОНаказании.НайтиПоНомеру(Док.НомерДок,Док.ДатаДок).Пустая() Тогда
                НовыйДокумент = Документы.ПриказОНаказании.СоздатьДокумент();
           
                НовыйДокумент.ДатаЗадержания=Дата(Формат(Док.ДатаЗадержания,"ДФ=yyyyММдд"));
                НовыйДокумент.Сотрудник=Док.Сотрудник.Наименование;
                НовыйДокумент.Должность=Док.Должность.Наименование;
                НовыйДокумент.Подразделение=Док.Подразделение.Наименование;
                НовыйДокумент.Причина=Док.Причина.Наименование;
                НовыйДокумент.Основание=Док.Основание;
                НовыйДокумент.Прочее=Док.Прочее;
                Сообщить("ДатаЗадержания:"+" "+ НовыйДокумент.ДатаЗадержания + " " + "Сотрудник:"+ " " + НовыйДокумент.Сотрудник + " " + "Должность:"+" " + НовыйДокумент.Должность + " " + "Подразделение:"+" "+ НовыйДокумент.Подразделение + " " + "Причина:"+" "+ НовыйДокумент.Причина + " " + "Основание:"+ " "+ НовыйДокумент.Основание + " " + "Прочее:"+ " " + НовыйДокумент.Прочее);
           
                НовыйДокумент.Записать(РежимЗаписиДокумента.Запись);
                ДокНЗ = НовыйДокумент.ЭтотОбъект;
              ДокНЗ.Записать(РежимЗаписиДокумента.Запись);
            КонецЕсли;
         КонецЕсли;
    КонецПроцедуры
    Это сообщение (ДатаЗадержания: 05.03.2008 0:00:00 Сотрудник: Должность: Подразделение: Причина: нетрезвое Основание: акт )

    {Форма.Форма.Форма(1424)}: Ошибка при вызове метода контекста (Записать)
    НовыйДокумент.Записать(РежимЗаписиДокумента.Запись);
    по причине:
    Значение поля "Дата" не может быть пустой датой
    Последнее редактирование: 21 фев 2014
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    Оформляйте код тегами code
  3. TopicStarter Overlay
    SpiritAT
    Offline

    SpiritAT Опытный в 1С

    Регистрация:
    8 авг 2013
    Сообщения:
    157
    Симпатии:
    0
    Баллы:
    26
    сп не нашол где
  4. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Вы пишите реквизит
    НовыйДокумент.ДатаЗадержания
    А у документа по умолчанию есть предопределенный реквизит
    Дата
    Реквизиты Дата и Номер ключевые и их нужно заполнять всегда
    Преобразование Дата() работает для строки типа "20080101" или "20080101000000", если у Вас там строка отличного вида, то преобразование выполнить не удастся
  5. TopicStarter Overlay
    SpiritAT
    Offline

    SpiritAT Опытный в 1С

    Регистрация:
    8 авг 2013
    Сообщения:
    157
    Симпатии:
    0
    Баллы:
    26
    сп попробую

Поделиться этой страницей