7.7 Создание документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Efremovich, 18 май 2009.

  1. TopicStarter Overlay
    Efremovich
    Offline

    Efremovich

    Регистрация:
    30 мар 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Друзья покажите как создать документ к примеру "Сличительная ведомость" (конфа "Рарус Общепит 6.0 на Бух4.5 )
    Воощем смысл прост есть Терминал сбора данных с помощью которого мы произвели инвентаризацию ("сличительную ведомость") есть обработка которая считывает данные с терминала и создаёт новый документ и вставляест туда данные с терминала в колонку Количество Фактическое находит себестоимость и выводит сумму, но вот беда не заполняет колонку КоличествоКнижное, а оно заполняется из формы документа с помощю БухИтогов по счетам
    Код:
    		спСчетов=СоздатьОбъект("СписокЗначений");
    Если Склад.ВидСклада=Перечисление.ВидыСкладов.Розничный Тогда 
    спСчетов.ДобавитьЗначение(СчетПоКоду("41.2")); // товар в рознице
    Иначе 
    спСчетов.ДобавитьЗначение(СчетПоКоду("41.1")); //товар на складе
    КонецЕсли; 
    Если Склад.ВидСклада=Перечисление.ВидыСкладов.Розничный Тогда 
    спСчетов.ДобавитьЗначение(СчетПоКоду("43.22")); // по блюдам в рознице
    спСчетов.ДобавитьЗначение(СчетПоКоду("43.32")); 
    Иначе 
    спСчетов.ДобавитьЗначение(СчетПоКоду("43.2")); 
    спСчетов.ДобавитьЗначение(СчетПоКоду("43.3")); // по блюдам на складе
    КонецЕсли;
    
    
    Не будете ли вы так любезны привести пример в котором перед тем как выгрузить данные моя обработка заполняла документ остатками на складе ,а уж потом находила по штрихкоду строку и меняла значение в колонке КоличествоКнижное.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Приблизительно так
    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,, 1);
    Ит.ВыполнитьЗапрос(ДатаДок, ДатаДок, спСчетов,,, 1,, "СК");
    Ит.ВыбратьСубконто(ВидыСубконто.Номенклатура);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл
    Товар=Ит.Субконто(ВидыСубконто.Номенклатура);
    Количество=Ит.СНД(3);
    КонецЦикла;
    
    

Поделиться этой страницей