8.х Создание цикла

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Margosha2502, 11 авг 2016.

  1. TopicStarter Overlay
    Margosha2502
    Offline

    Margosha2502

    Регистрация:
    10 авг 2016
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Есть общий модуль для регламентного задания по отправке трех отчетов на почту.
    Вот часть кода:

    &НаСервере
    Процедура Отчет() Экспорт
    ТекстПисьма = "Отчет по ... за " + Строка(НачалоДня(ТекущаяДата())-60*60*16) + " - " + Строка(НачалоДня(ТекущаяДата())+60*60*8) + Символы.ПС;
    Таб = СоздатьОтчет(ТекстПисьма);
    КопияТаб = СоздатьНовыйОтчет(ТекстПисьма);
    КопияКопияТаб = СоздатьНовыйНовыйОтчет(ТекстПисьма);

    ПутьКФайлу1 = "C:\Users\Public\";
    ИмяФайла1 = "Закрытие инцидентов по линиям.xls";
    ПолноеИмяФайла1 = ПутьКФайлу1+ИмяФайла1;

    ВыгрузитьТДвФайл(Таб, ПолноеИмяФайла1, ТекстПисьма);

    ПутьКФайлу2 = "C:\Users\Public\";
    ИмяФайла2 = "Статистика выполнения обращений в срок.xls";
    ПолноеИмяФайла2 = ПутьКФайлу2+ИмяФайла2;

    ВыгрузитьТДвФайл(КопияТаб, ПолноеИмяФайла2, ТекстПисьма);

    ПутьКФайлу3 = "C:\Users\Public\";
    ИмяФайла3 = "Контрольная карта - количество обращений.xls";
    ПолноеИмяФайла3 = ПутьКФайлу3+ИмяФайла3;

    ВыгрузитьТДвФайл(КопияКопияТаб, ПолноеИмяФайла3, ТекстПисьма);

    ОтправкаУведомлений(ТекстПисьма, ПолноеИмяФайла1);
    ОтправкаУведомлений(ТекстПисьма, ПолноеИмяФайла2);
    ОтправкаУведомлений(ТекстПисьма, ПолноеИмяФайла3);
    КонецПроцедуры


    Далее идут функции по созданию каждого отчета.
    Можно ли связать их как-нибудь с помощью цикла и как этот цикл написать, пожалуйста, подскажите
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Ээээ....

    &НаСервере

    Процедура ФормированиеИОтправкаОтчетов()

    Для сч=0 по 1 Цикл

    Отчет();
    ......
    ........

    КонецЦикла;

    КонецПроцедуры
  3. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.023
    Симпатии:
    51
    Баллы:
    54
    В данном случае какой смысл в цикле??
    У вас "Отправка 3-х отчетов".
    Другое дело, если бы вы не знали, сколько отчетов будет отправляться, тогда формировали бы массив с текстами и именем файла и уже цикл по массиву запускали
  4. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    У меня так акты сверок формируются и отправляются на почту контрагентам.

Поделиться этой страницей