[РЕШЕНО] Сохранение внешних обработок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Kurt_89, 20 мар 2014.

  1. TopicStarter Overlay
    Kurt_89
    Offline

    Kurt_89 Опытный в 1С

    Регистрация:
    2 апр 2011
    Сообщения:
    85
    Симпатии:
    0
    Баллы:
    26
    Процедура обходит по циклу все внешние обработки и сохраняет их в указанную директорию.
    Файлы в папке создаются и имеют разный размер, но если открыть обработку в конфигураторе у него нет ни реквизитов ни форм. Как быть?
    Код:
    ДиалогФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);  
        Если ДиалогФайла.Выбрать() Тогда
            Каталог = ДиалогФайла.Каталог;
        КонецЕсли;
        Выборка = Справочники.ВнешниеОбработки.Выбрать();
        Пока Выборка.Следующий() Цикл
            ДвоичныеДанные = Выборка.ХранилищеВнешнейОбработки.Получить();
            Если ДвоичныеДанные = Неопределено Тогда
                Продолжить;
            Иначе
                ДвоичныеДанные.Записать(Каталог + "\" + Выборка.ВидОбработки + " - " + Выборка.Код + " - " + Выборка.Наименование + ".erf");
            КонецЕсли;
            Для каждого ТекСтрока Из Выборка.Принадлежность Цикл
              
                    ДвоичныеДанные = ТекСтрока.ХранилищеВнешнейОбработки.Получить();
                    Если ДвоичныеДанные = Неопределено Тогда
                        Продолжить;
                    Иначе
                        ДвоичныеДанные.Записать(Каталог + "\" + Выборка.ВидОбработки + " - " + Выборка.Код + " - " + ТекСтрока.ПредставлениеОбъекта + " - " + Выборка.Наименование + ".erf");      
                    КонецЕсли;
                      
                КонецЦикла;
        КонецЦикла;
    
    1.PNG 2.PNG
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    399
    Баллы:
    104
    Что мешает открыть любую типовую и подглядеть этот механизм там?
  3. TopicStarter Overlay
    Kurt_89
    Offline

    Kurt_89 Опытный в 1С

    Регистрация:
    2 апр 2011
    Сообщения:
    85
    Симпатии:
    0
    Баллы:
    26
    В типовой так и реализовано, только вот работает некорректно из внешней обработки)
    Последнее редактирование: 20 мар 2014
  4. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну так судя по названию это у вас внешняя обработка, а вы сохранили ее как внешний отчет. Поменяйте расширение.
  5. TopicStarter Overlay
    Kurt_89
    Offline

    Kurt_89 Опытный в 1С

    Регистрация:
    2 апр 2011
    Сообщения:
    85
    Симпатии:
    0
    Баллы:
    26
    Спасибо. И правда расширение, как то не заметил))

Поделиться этой страницей