7.7 Сохранение файла (расширение)

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Йогурт, 17 окт 2006.

  1. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Всем здравствуйте! Если я не в той ветке извините плиз не пинайте а направте в нужную.
    Я в ентом деле (в смысле 1С далек от каких-либо знаний, всё методом тыка, но кое-что получается. Сначала объясню, что требуется, а затем - что я сделал и что нет.
    Требуется из документа ПеремещениеТМЦ создать фактуру и переслать её на e-mail. Та форма которая выводится по кнопке Печать не полностью устраивает, а отредактировать её не знаю как, не нашёл где она "зарыта". :D Потому создал печатную свою форму по другой кнопке, с помощью конструктора. Форма устраивает, а вот процесс её сохранения - нет. B) У меня на этот счёт два пожелания:
    - либо, чтобы при сохранении первым предлагалось разрешение не .mxl, а .xls;
    - либо чтобы по "моей" кнопке форма не выводилась на экран, а сохранялась в определённом месте, опять же в формате Excel (которое, опять же, хотелось бы один раз задать и дальше об этом не вспоминать).
    Помогите кто чем может, ПЛИЗЗЗ :unsure:
  2. ivan-black
    Offline

    ivan-black

    Регистрация:
    18 окт 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Не получиться.
    Добавь в модуле документа, в конце процедуры где формируется твоя форма:
    таблица.записать(ИмяФайла,"XLS");
    Где ИмяФайла - Имя твоего файла с указанием пути, например "c:\faktura"
  3. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Тогда есчё вопрос. А можно ли сделать так, чтобы при сохранении имя состояло из наименования склада отправителя и склада получателя. Например: "Склад№1 _ Склад№2". Просто фактур будет много и я так понимаю, если сделать по Вашему примеру, программа будет их перезаписывать. И опять же, если вдруг попадётся две фактуры с одинаковыми "Складами", как сделать, чтобы они не перезаписывались, а например второй фактуре присваивался, допустим, №2. :unsure:
    Заранее, спасибо! B)
  4. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    дык имяфайла это строка - пихай туда что хочешь.
    а присваивать новые номера - проверяе есть ли файл с таким именем.

    Сч=1;
    Пока ФС.СуществуетФайл(Склад1.Наименование+"_"+Склад2.Наименование+Сч+".xls") = 1 Цикл
    Сч=Сч+1;
    КонецЦикла;
    Таблица.Записать(Склад1.Наименование+"_"+Склад2.Наименование+Сч,1)
  5. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    С именем файла всё получилось, а вот с проверкой нет. Выскакивает ошибка:"Слишком много параметров передано при вызове функции/процедуры объекта". B) Что это значит??? :unsure:
  6. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Знаит что-то неправильно написал, т.к. передается всего один параметр - имя файла (и полный путь к нему)
  7. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    У меня вот что получилось:
    Процедура фак()

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("фак");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,0,0);
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать Перемещение ТМЦ","");
    Сч=1;
    Пока ФС.СуществуетФайл("c:\1с\От "+Склад.Наименование+" на "+СкладПолучатель.Наименование+Сч+"","XLS") = 1 Цикл
    Сч=Сч+1;
    КонецЦикла;
    Таб.Записать("c:\1с\От "+Склад.Наименование+" на "+СкладПолучатель.Наименование+Сч,1);
    КонецПроцедуры
    А при попытке сохранения в табло выходит:
    Пока ФС.СуществуетФайл("c:\1с\От "+Склад.Наименование+" на "+СкладПолучатель.Наименование+Сч+"","XLS") = 1 Цикл
    {Документ.ПеремещениеТМЦ.Форма.Модуль(1528)}: Слишком много параметров передано при вызове функции/процедуры объекта
    Где я накосячил? :unsure:
  8. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Где ты увидел запятую в моем примере перед "XLS"?
  9. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    B) Точно!! :wub: Всё работает :D СЕНКЬЮ :D
    Можно есЧё вопросик. В остатках после точки выводятся ТРИ нуля, а можно их вместе с точкой упраздинть? :unsure:
  10. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Формат(ТвоеЗначение,"Ч15.0")
  11. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    А чего материться то!!! B) Я же писал, что я ничего не знаю, а всё методом тыка. Куда это вписать? В остатках поискал, не придумал куда.
    Я бы с удовольствием не задавал таких глупых вопросов, но у меня нет литературы по программированию в 1С. В сети поискал, не нашёл. Кстати, если знаете где можно скачать (бесплатое :D ) пособие, подскажите, плиззз. :unsure:
  12. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    По поводу доков - были вопросы по форуму, точно не помню уже где - заюзай "поиск"... (по запросу "учебник" 6-7 линков точно есть тут :))
  13. Taxist
    Offline

    Taxist

    Регистрация:
    16 окт 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Подъедь на Селезнёвку да купи. Копейки
  14. TopicStarter Overlay
    Йогурт
    Offline

    Йогурт

    Регистрация:
    17 окт 2006
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    B) Вся прелесть в том, что 1С я занимаюсь иногда и то для себя (ради интереса), поэтому покупать книги чтобы они большую часть времени просто лежали в ящике стола не хочу. Это первое. А второе: Селезнёвка - это вообще где? :unsure: Я в Новосибирске живу :D

Поделиться этой страницей