8.х Составное имя переменной

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем desintegrer, 10 июл 2013.

  1. TopicStarter Overlay
    desintegrer
    Offline

    desintegrer Опытный в 1С

    Регистрация:
    11 май 2011
    Сообщения:
    377
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте подскажите пожалуйста как сделать составное имя переменной ?

    я сделал так и не работает :

    Код:
    Для Каждого Строка Из ТранспортныеСредстваДляЗаполнения Цикл  ОбработкаПрерыванияПользователя();
    СтрокаТаблицы = СтрокаТаблицы + 1 ;
    
    ЗначениеТС[СтрокаТаблицы] = Строка.ТС;
    ЗначениеЗаказчик[СтрокаТаблицы] = Строка.Заказчик;
    ЗначениеПеревозчик[СтрокаТаблицы] = Строка.Перевозчик;
    КонецЦикла; 
    
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    переменную СтрокаТаблицы необходимо инициализировать до цикла
    что-нибудь типа СтрокаТаблицы = 0;
  3. TopicStarter Overlay
    desintegrer
    Offline

    desintegrer Опытный в 1С

    Регистрация:
    11 май 2011
    Сообщения:
    377
    Симпатии:
    0
    Баллы:
    26
    Вообще-то так и делал . но попробую ещё раз .
  4. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.358
    Симпатии:
    5
    Баллы:
    29
    СтрокаТаблицы =0;
    Для Каждого Строка Из ТранспортныеСредстваДляЗаполнения Цикл ОбработкаПрерыванияПользователя();
    СтрокаТаблицы = СтрокаТаблицы + 1;

    ЗначениеТС[СтрокаТаблицы] = Строка.ТС;
    ЗначениеЗаказчик[СтрокаТаблицы] = Строка.Заказчик;
    ЗначениеПеревозчик[СтрокаТаблицы] = Строка.Перевозчик;
    КонецЦикла;

    как советовали выше

    Для Каждого Строка=1 Из ТранспортныеСредстваДляЗаполнения.Количество()-1 Цикл
    ОбработкаПрерыванияПользователя();


    ЗначениеТС[Строка] = ТранспортныеСредстваДляЗаполнения[Строка].ТС;
    ЗначениеЗаказчик[Строка] = ТранспортныеСредстваДляЗаполнения[Строка].Заказчик;
    ЗначениеПеревозчик[Строка] = ТранспортныеСредстваДляЗаполнения[Строка].Перевозчик;
    КонецЦикла;


    или так попробуй

Поделиться этой страницей