8.х SOS- =((((((

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем GP_, 12 окт 2006.

  1. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Надо НАписать Простой отчёт : Пребреть все доки чек и сгруппировать их по сотрудникам написанным в табличной части , вывевсти на экран таблицу (Имя | Сумма по всем документам | Кол-во документов с его фамилией)

    Уже час бъюсь надоело !!!! помогите плз.
  2. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    ну для первого раза нормально бьешься :) еще помучайся.. получится... главное сделать правильный запрос
  3. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Лучше бы помог =(((( Я уже просто туплю в моник .....
  4. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    конфа стандартная?
  5. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    УТ немного модифицированнная . мне просто в разрезе продавца нужно узнать поличество докуменов чекККМ
  6. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    завтра с утра продолжу... мозги кипят
  7. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Кстати плз если у тебя есть кинь описуху типовоу УП и УТ Ну и БУ =))))))) а то конфы есть а книгам ноги приделали =(
  8. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    вот не поверишь все в печатном виде :((((((
  9. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    =((((((((((((((((((((((((((((( Если вдруг найдёшь в цифровом , laman45@mail.ru - буду очень признателен.... ТАк вот напиши мне пожалуйста как в 8 тупо перебрать документы
  10. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Код:
    ВыборкаДокументов = Документы.Расходная.Выбрать(НачалоГода(ТекущаяДата()), КонецГода(ТекущаяДата())); 
    Пока ВыборкаДокументов.Следующий() Цикл 
    
    // Действия с документом - элементом выборки, 
    // его значение содержится в переменной ВыборкаДокументов 
    
    КонецЦикла 
    
    
    или
    Код:
    Запрос = Новый Запрос; 
    Запрос.Текст = " 
    |ВЫБРАТЬ 
    |    РеализацияТоваровУслуг.Ссылка 
    |ИЗ 
    |    Документ. РеализацияТоваровУслуг КАК РеализацияТоваровУслуг 
    |ГДЕ 
    |    РеализацияТоваровУслуг.Контрагент = &Контрагент 
    |    И 
    |    (РеализацияТоваровУслуг.Номер < 100 | ИЛИ | РеализацияТоваровУслуг.Дата < ДАТАВРЕМЯ(2005, 1, 1)) 
    |    И 
    |    РеализацияТоваровУслуг.Товары.Номенклатура В ИЕРАРХИИ(&Номенклатура)"; 
    
    Запрос.УстановитьПараметр("Контрагент", ОтбКонтрагент); 
    Запрос.УстановитьПараметр("Номенклатура", ОтбНоменклатура); 
    
    Результат = Запрос.Выполнить(); 
    Выборка = Результат.Выбрать(); 
    Пока Выборка.Следующий() Цикл 
    
    // действия с документом - элементом выборки, 
    // его значение содержится в переменной Выборка 
    
    КонецЦикла; 
    
  11. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    итог=0;
    ВыборкаДокументов = Документы.ЧекККМ.Выбрать(НачалоГода(ТекущаяДата()), КонецГода(ТекущаяДата()));
    Пока ВыборкаДокументов.Следующий() Цикл
    Сообщить("Чтение документа");
    ч = ВыборкаДокументов.ЧекККМ.Товары.Найти(Продавец,"Продавец");
    Если ч <> Неопределено Тогда
    Итог = Итог + 1 ;

    КонецЕсли;
    КонецЦикла ;
    Сумм = Итог;
    Итог=0;
    Сообщить(сумм);
    КонецПроцедуры

    ЧТо НЕ так ???? он не находит в доках продавца
  12. zbv
    Offline

    zbv

    Регистрация:
    10 окт 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    ч = ВыборкаДокументов.Товары.Найти(Продавец,"Продавец");
  13. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    он не находит записей и говорит что продовца в документах нет (он там есть точно сам забивал). Блин чем им не нравилась система из 7-ки =(
  14. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    итог=0;
    ВыборкаДокументов = Документы.ЧекККМ.Выбрать(НачалоГода(ТекущаяДата()), КонецГода(ТекущаяДата()));
    Пока ВыборкаДокументов.Следующий() Цикл
    Для Каждого ТекущаяСтрока Из ВыборкаДокументов.Товары Цикл

    // Действия со строкой табличной части.
    КолСтр = ВыборкаДокументов.Товары.Количество() - 1;
    Для Сч = 0 по КолСтр Цикл
    Если СОКРЛП(ВыборкаДокументов.Товары.Получить(СЧ).Продавец) = СОКРЛП(Продавец.Ссылка.Наименование) ТОгда
    // Действия со строкой табличной части.
    Итог = Итог + 1 ;
    Прервать;
    КонецЕсли;
    //сООБЩИТЬ(+ ","+ СОКРЛП(Продавец.Наименование));
    КонецЦикла;


    КонецЦикла;
    КонецЦикла ;
    сообщить("Всего документов : " + Итог);
    Сумм = Итог;
    Итог=0;

    КонецПроцедуры



    Переделал вот так... но не могу сравнить строку из документа и реквизит обработки

Поделиться этой страницей