7.7 Сортировка!!!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AlexLink, 7 дек 2015.

  1. TopicStarter Overlay
    AlexLink
    Offline

    AlexLink

    Регистрация:
    12 янв 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Подскажите как отсортировать данные в табличной части документа по принципу а-я a-z?
    По умолчанию сортирует a-z а-я. Это нужно для печати списка. Спасибо!
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    не понял
    --- Объединение сообщений, 7 дек 2015 ---
    ааа, блин, дошло
    там сперва англиций идёт, а потом русский
    точнее символы, цифры, латиница и русский

    что вы хотите то?
    таб.часть не обязательно трогать при формировании списка :)
    это можно в коде учесть
  3. TopicStarter Overlay
    AlexLink
    Offline

    AlexLink

    Регистрация:
    12 янв 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    :) Именно так.
    У меня в таб.части колонки: №, Товар, Производитель, Цена.
    Товар у меня есть на латинице и есть на русском.
    При формировании списка весь товар идет из табличной части документа и если там сделать сортировку по колонке то сразу идет на латинице затем на русском, а нужно что бы было наоборот.
    Таб часть там в принципе не важно что и как, главное что бы в списке было как надо, а вот с этим проблема.
    Код:
    Процедура ПриОткрытии()
        ПриЗаписиПерепроводить(1);
    КонецПроцедуры
    //********************************************************
    Функция Ном()
        ном = 0;
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
        ном = ном + 1;
        КонецЦикла;
        Возврат ном;
    КонецФункции
    //********************************************************
    Процедура Подбор()
    ОткрытьПодбор("Справочник.Номенклатура");  
    КонецПроцедуры
    //********************************************************
    Процедура ОбработкаПодбора(ВыбрТовар)
        Цен=1;
        Если ВвестиЧисло(Цен,"Введите цену",10,0)=0 Тогда
            Возврат;
        КонецЕсли;
        НоваяСтрока();
           Наименование = ВыбрТовар;
        Страна = ВыбрТовар.Страна;
        Цена = Цен;   
        АктивизироватьСтроку();
    КонецПроцедуры
    //********************************************************
    Процедура Печать()
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Таблица");
        Таб.ВывестиСекцию("Шапка");
        ном = 0;
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            Ном = Ном + 1;
            Таб.ВывестиСекцию("Строка");                      
        КонецЦикла;
        Таб.Опции(0,0,0,0,"ОпцииПечатиМ4","ОкноМ4");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать протокола");
    КонецПроцедуры // Печать    
    //********************************************************
    Процедура Сорт() 
      
    КонецПроцедуры
    
    Последнее редактирование: 7 дек 2015
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Разделять товар в ТЧ на 2 списка и сортировать по отдельности.
  5. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    405
    Симпатии:
    71
    Баллы:
    54
    Здравствуйте.
    Добавьте еще одну колонку с признаком раскладки (0 и 1, например). Раскладку определите по коду первого (если достаточно) символа. Потом сортируйте по этой колонке и наименованию.
  6. TopicStarter Overlay
    AlexLink
    Offline

    AlexLink

    Регистрация:
    12 янв 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Спасибо. :)
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    да. так лучше. вы правы
Похожие темы
  1. NataT
    Ответов:
    2
    Просмотров:
    1.114
  2. DFA
    Ответов:
    5
    Просмотров:
    535
Загрузка...

Поделиться этой страницей