7.7 Сортировка в отчете "Журнал выставленных и полученных счет-фактур"

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем spartak_lp, 9 июн 2012.

  1. TopicStarter Overlay
    spartak_lp
    Offline

    spartak_lp Опытный в 1С

    Регистрация:
    3 окт 2011
    Сообщения:
    201
    Симпатии:
    0
    Баллы:
    26
    Добрый день! Помогите пожалуйста настроить сортировку в отчете "Журнал выставленных и полученных счет-фактур по Постановлению 1137" по 5-й колонке "Номер счет-фактуры", а то почему-то после строк с невыставленными счетами-фактурами идут выставленные, но с порядковым номером и датой СФ меньшей предыдущих (на рис. видно). Нужно чтобы по порядку шел список.
    Конф. 1С 7.70.537 Бухучет.

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Поменять местами группировки в запросах процедур СчетаФактурыВыданные() и СчетаФактурыПолученные()
  3. TopicStarter Overlay
    spartak_lp
    Offline

    spartak_lp Опытный в 1С

    Регистрация:
    3 окт 2011
    Сообщения:
    201
    Симпатии:
    0
    Баллы:
    26
    А какие именно группировки нужно менять? Где-то тут?:
    Код:
    Если СтандартнаяФорма = 0 Тогда
    Если ГруппироватьПоКонтрагентам = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка Контрагент;";
    КонецЕсли;
    КонецЕсли;
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка ДатаВыставления;
    |Группировка Док;
    |Функция ВсегоПродаж = Сумма(ПересчетПР(Док,Всего));
    |Функция ВсегоКУменьшению = Сумма(ПересчетПР(Док,КУменьшению));
    |Функция ВсегоКДоплате = Сумма(ПересчетПР(Док,КДоплате));
    |Функция ВсегоНДС = Сумма(ПересчетПР(Док,НДС));
    |Условие((Выставлен = 1) ИЛИ (СчетФактураНеВыставляется = 1));";
    Если СтандартнаяФорма = 0 Тогда
    Если ВыбКонтрагент.Выбран() = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Условие (Контрагент в ВыбКонтрагент);";
    КонецЕсли;
    КонецЕсли;
    
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Предупреждение("Невозможно выполнить запрос");
    Возврат;
    КонецЕсли;
    
    Ном = 1;
    Пока Запрос.Группировка(1) = 1 Цикл
    Если (СтандартнаяФорма = 1) или (ГруппироватьПоКонтрагентам = 0) Тогда
    Пока Запрос.Группировка(2) = 1 Цикл
  4. TopicStarter Overlay
    spartak_lp
    Offline

    spartak_lp Опытный в 1С

    Регистрация:
    3 окт 2011
    Сообщения:
    201
    Симпатии:
    0
    Баллы:
    26
    Кажется разобрался. Изменил на такой запрос:
    Код:
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка НомерСчетаФактуры;
    |Группировка Док;
    
    Теперь по порядку номера СФ выходит, спасибо.
Похожие темы
  1. spartak_lp
    Ответов:
    6
    Просмотров:
    3.632
  2. skurser
    Ответов:
    10
    Просмотров:
    3.469
  3. consol
    Ответов:
    8
    Просмотров:
    1.462
  4. Одинец
    Ответов:
    0
    Просмотров:
    641
  5. a-1962
    Ответов:
    4
    Просмотров:
    774
Загрузка...

Поделиться этой страницей