7.7 Сортировка Списка Значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем vall-n-rol, 5 ноя 2011.

  1. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    Дело в том что в Список значений элементы попадают в одном порядке а на выходе он автоматом сортирует их по коду по возрастанию хотя я сортировку не ставил, возможно ли получить со списка значения в том порядке в котором они попадают?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если вы не сортируете то 1с этого автоматически тоже не делает. Смотрите в коде где у вас изменяется порядок...
    Какие образом вы заполняете список?
  3. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26

    Заполняю через выборку со справочника:
    Код:
    ЛСЧ.ВыбратьЭлементы(1);	
    Пока ЛСЧ.ПолучитьЭлемент()>0 Тогда
    Если ЛСЧ.ППометкаУдаления() = 1 Тогда 
    продолжить;
    КонецЕсли;         
    Если ЛСЧ.ЭтоГруппа() = 1 Тогда  
    продолжить;
    КонецЕсли;
    спЛСЧ.ДобавитьЗначение(ЛСЧ.ТекущийЭлемент());  
    КонецЦикла;   
    Бухит...................................................
    Бухит.ИспользоватьСубконто(ВидыСубконто.дмвЛецевыесчита,спЛСЧ);
    Бухит.ВыполнитьЗапрос.............
    Бухит.ВыбратьСубконто();
    Пока Бухит.ПолучитьСубконто()=1 Цикл
    Абонент=Бухит.Субконто();
    
    - вот сдесь он уже выводит их по коду а мне нужно чтоб порядок был такойже когда выборка идет сосправочника отбор идет по элементы так как он идет в иирархии
    как быть
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Хм... Так списком вы просто задаете ФИЛЬТР, а результат получаете в порядке запроса БИ. Почувствуйте разницу.... Если нужно сортировать - выгружайте в новый список или таблицу значений...

Поделиться этой страницей