7.7 сортировка по контрагентам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ZEMA, 5 окт 2007.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    Привет :unsure: Помогите, что не так?
    надо в отчёте чтобы данные были отсортированы по контрагентам,вот то что я делаю (я недавно начала программировать в 1с)
    появляется такая ошибка
    ==================================

    Код:
    Процедура Сформировать() 
    Перем Пере,Запрос, ТекстЗапроса, Ист;
    
    Т = СоздатьОбъект("ТаблицаЗначений"); 
    
    Т.НоваяКолонка("Контрагент","Справочник.Контрагенты");
    Т.НоваяКолонка("Сумма","Число",15,2);
    Т.НоваяКолонка("Ра","Документ.ПлатежноеПоручение");
    
    Ра= СоздатьОбъект("Документ.ПлатежноеПоручение");
    Ра.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода); 
    
    Т.Сортировать("Сумма");    
    
    Таб = СоздатьОбъект("Таблица");
    Таб.Выгрузить(Т);
    Таб.ВывестиСекцию("Шапка");  
    i=0;
    Пока Ра.ПолучитьДокумент()=1 Цикл
    Если ВыбКлиент.Принадлежит(Ра.ТекущийДокумент().Контрагент)=0 Тогда
    Продолжить;
    КонецЕсли;    
    Т.НоваяСтрока();
    ПечКон= Ра.Контрагент;
    ПечСум=Ра.Сумма;
    ПечДок=Ра.ТекущийДокумент(); 
    i=i+1;
    Таб.ВывестиСекцию("Текущийдокумент"); 
    КонецЦикла;
    
    Таб.Опции(1, 1, 0, 0);  
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", ""); 
    КонецПроцедуры
    
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Содержательный пост...
    Что за отчет? Типовой? Самописный?
    Код запроса покажи.
  3. Raspr
    Offline

    Raspr

    Регистрация:
    14 апр 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Меня тоже очень сильно интересует вопрос, какими способами можно сделать сортировку документов по контрагентам?! Я вообще еще чайник в этой области, но ооочень сейчас приспичило!!! Хэлп!!!
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Сделать перебор нужных документов по датам или запросом, собрать эти данные в ТЗ, с выделенной колонкой под контрагентов. Отсортировать по этой колонке и вывести данные в печатную форму.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Приблизительно так
    Код:
    Тз = СоздатьОбъект("ТаблицаЗначений");
    Тз.НоваяКолонка("Документ");
    Тз.НоваяКолонка("Контрагент");
    
    Док = СоздатьОбъект("Документ.КакойТоВид");
    Док.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода); 
    Пока Док.ПолучитьДокумент()=1 Цикл
    ТЗ.Документ=Док;
    ТЗ.Контрагент=Док.Контрагент;
    КонецЦикла;
    Т.Сортировать("Контрагент");        
    
    //вывод таблиц через цикл
    
    
    
  6. X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    А по-моему, через запрос проще. Заадать нужные группировки и сортировать, как пожелаешь.
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Согласен что проще, но человек только учится.... а ты его сразу запросом по голове))))))))))))
  8. X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Учиться нужно сразу правильно:)
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Я сам преподавал в ТГУ. Человеку сначала нужно нучиться ходить, а потом уже садиться за руль мерседеса

Поделиться этой страницей