8.х сортировка массива

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем auricomwxl, 6 мар 2010.

  1. TopicStarter Overlay
    auricomwxl
    Offline

    auricomwxl

    Регистрация:
    4 янв 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Привет!
    При сохранении выдает ошибку:

    {Обработка.Массивы.Форма.Форма(73,18)}: Тип не определен (сзСотр)
    сзСотр = новый <<?>>сзСотр;

    Код:
    Процедура Кнопка5Нажатие(Элемент)
    сзСотр = новый сзСотр;
    мас = Новый Массив;  
    мас.Добавить("Иванов");  
    мас.Добавить("Якушин");  
    мас.Добавить("Сидоров");  
    сзСотр.ЗагрузитьЗначения(мас);  
    сзСотр.СортироватьПоЗначению();  
    мас2 = сзСотр.ВыгрузитьЗначения(); 
    Сообщить(мас2);
    i=0;
    Пока i<мас2.Количество() Цикл
    Сообщить(Строка(мас2[i]));
    i=i+1;
    КонецЦикла; 
    КонецПроцедуры
    
    
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    1. Кхм, а что это за тип такой? Видимо, СписокЗначений?
    2. Что должен делать этот код? В нем никакого смысла...
  3. TopicStarter Overlay
    auricomwxl
    Offline

    auricomwxl

    Регистрация:
    4 янв 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Кнопка5Нажатие(Элемент)
    сзСотр = новый сзСотр;
    мас = Новый Массив;  
    мас.Добавить("Иванов");  
    мас.Добавить("Якушин");  
    мас.Добавить("Сидоров");  
    сзСотр.ЗагрузитьЗначения(мас);  
    сзСотр.СортироватьПоЗначению(НаправлениеСортировки.Убыв);  
    мас2 = сзСотр.ВыгрузитьЗначения(); 
    Сообщить(мас2);
    i=0;
    Пока i<мас2.Количество() Цикл
    Сообщить(Строка(мас2[i]));
    i=i+1;
    КонецЦикла; 
    КонецПроцедуры
    
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Еще раз:
    Я не вижу, откуда вы данные берете!
    мас - пустой, ибо только что создан.
    сзСотр - вообще некорректно создается...

    Что это за код?
  5. TopicStarter Overlay
    auricomwxl
    Offline

    auricomwxl

    Регистрация:
    4 янв 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Это СписокЗначений.. Я вроде нажал на кнопку "Спасибо")))
Похожие темы
  1. Nik_Nik
    Ответов:
    2
    Просмотров:
    443
Загрузка...

Поделиться этой страницей