7.7 сортировка контрагентов

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем 1alex_patron, 28 фев 2013.

  1. TopicStarter Overlay
    1alex_patron
    Offline

    1alex_patron

    Регистрация:
    28 фев 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте,я не программист, и недавно работаю с 1с(так сказать полный чайник), на основе существующего отчета сделал отчет,

    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;   
    глНачДата=ВыбНачПериода;
    глКонДата=ВыбКонПериода;
    
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Контрагент = Регистр.ВзаиморРасчеты.Контрагент;
    |Сумма = Регистр.ВзаиморРасчеты.Сумма;
    |Округ = Регистр.ВзаиморРасчеты.Округ;
    |Функция СуммаНачОст = НачОст(Сумма);
    |Функция СуммаПриход = Приход(Сумма);
    |Функция СуммаРасход = Расход(Сумма);
    |Функция СуммаКонОст = КонОст(Сумма);
    |Группировка Контрагент ;	 
    |"//}}ЗАПРОС
    ;		   
    
    Если ВыбОкруг.Выбран()=1 Тогда
    ТекстЗапроса=ТекстЗапроса+
    "
    |Условие(Контрагент.Округ = ВыбОкруг);
    |"
    ;
    КонецЕсли;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Контрагент
    Таб.ВывестиСекцию("Контрагент");
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    Процедура ОтчиститьОкруг()
    ВыбОкруг="";
    КонецПроцедуры

    прописываю "Группировка Контраген упорядочить по Контрагент.Адрес_Номер" он в итоге сортирует по "Номер" 1,10,11,2,20,21........,а надо 1,2,10,11,20,21.....,я знаю,что есть "Сортировать",но как и куда ее прописать не знаю
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Судя по всему, сортируются данные типа строка. Поэтому получается такая сортировка. Либо нужно сортировать по числовому реквизиту, либо после получения результата запроса его приводить к требуемому виду (например через ТЗ и служебную колонку).
  3. TopicStarter Overlay
    1alex_patron
    Offline

    1alex_patron

    Регистрация:
    28 фев 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    я же написал ,что полный чайник,я пробовал через ТЗ но ничего не получается,я не знаю куда именно это все прописывать...и как прописывать :unsure:
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    строку можно привести к числу
    Код:
    чисто(вашастрока)
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    чисТо ваша строка? :))
    Это такая, распальцованая 1С?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ОчеПятка))))) Спасибо, рассмешил
  7. TopicStarter Overlay
    1alex_patron
    Offline

    1alex_patron

    Регистрация:
    28 фев 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо Добрые люди, что помогли
Похожие темы
  1. Ok.Pavel
    Ответов:
    3
    Просмотров:
    701
  2. monarx
    Ответов:
    1
    Просмотров:
    457
Загрузка...

Поделиться этой страницей