8.х Сообщить

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 15 окт 2014.

  1. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    Нужно сообщить пользователю если объект пустой!
    Код:
    &НаКлиенте
    Процедура ОрганизацияПриИзменении(Элемент)
        Если Объект.КурсПункт2.Пустая() Тогда
            Сообщить("Поставьте курс!!!");
            Возврат;        
        КонецЕсли;
    
    КонецПроцедуры
    
    ошибка
    upload_2014-10-15_10-52-16.png
    скажите пожалуйста где ошибка?
    Спасибо!
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    Объект.КурсПункт2 какой тип значения имеет?
  3. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    398
    Баллы:
    104
    1. Размещайте темы в соответствующих разделах.
    2. ЗначениеЗаполнено(). Проверяет любой тип.
    Гриша нравится это.
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    завалится на проверке объекта.
  5. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    398
    Баллы:
    104
    Если объект существует то не завалится.
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    в любом случае завалится по ошибке проверки мутабельного значения.
  7. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    тип число
    --- Объединение сообщений, 15 окт 2014 ---
    люди подскажите что делать?
    Последнее редактирование: 15 окт 2014
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    Проверять с помощью
    ЗначениеЗаполнено()
    или
    Объект.КурсПункт2 <> 0
  9. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Код:
    &НаКлиенте
    Процедура ОрганизацияПриИзменении(Элемент)
        Если Объект.КурсПункт2 <> 0 () Тогда
            Сообщить("Поставьте курс!!!");
            Возврат;        
        КонецЕсли;
    
    КонецПроцедуры
    
    ошибку дает
    Код:
    {Документ.Выезды1.Форма.ФормаДокумента.Форма(92,29)}: Ожидается ключевое слово 'Тогда' ('Then')
        Если Объект.КурсПункт2 <> 0<<?>> () Тогда (Проверка: Сервер)
    {Документ.Выезды1.Форма.ФормаДокумента.Форма(92,29)}: Ожидается ключевое слово 'Тогда' ('Then')
        Если Объект.КурсПункт2 <> 0<<?>> () Тогда (Проверка: Тонкий клиент)
    
    --- Объединение сообщений, 15 окт 2014 ---
    ошибки нет и не проверяет
    Код:
    &НаКлиенте
    Процедура ОрганизацияПриИзменении(Элемент)
        Если Объект.КурсПункт2 <> 0  Тогда
            Сообщить("Поставьте курс!!!");
            Возврат;        
        КонецЕсли;
    
    КонецПроцедуры
    
  10. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    проверяет. только курс на равенство 0 стоит проверять, если есть желание требовать заполнения :)
  11. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    а как правильно?
    сделал курс меньше нуля тоже не сообщает
  12. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    так в вашем случает проверять на равенство 0 надо, т.е.

    Код:
    &НаКлиенте
    Процедура ОрганизацияПриИзменении(Элемент)
        Если Объект.КурсПункт2 = 0  Тогда
            Сообщить("Поставьте курс!!!");
            Возврат;       
        КонецЕсли;
    
    КонецПроцедуры
  13. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Спасибо работает!
    Значить если объект = 0 то это объект не пуст поэтому не сообщал!
    Всем Спасибо!

Поделиться этой страницей