8.х Соединение через COM 1С7.7 и 1С8.0. Трабл.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alex-79, 20 авг 2007.

  1. TopicStarter Overlay
    alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Я подсоединяюсь из 1С7.7 в 1С8.0 через COM соединение. И мне нужно сделать выборку элементов справочника из 8-ки через это соединение. Я даже не знаю как создать объект. Подскажите где можно почитать про это или если не жалко скиньте кусок кода. :unsure:
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    V7 = Новый COMобъект("V77.Application");

    // пытаемся открыть базу
    Если Не V7.Initialize(V7.RMTrade,"""C:\Program Files\1Cv77\BIN\1cv7.exe"" enterprise /D """+ПутьКБазе+""" ,"NO_SPLASH_SHOW") Тогда
    Предупреждение("Ошибка открытия информационной базы!
    |Возможно требуется переиндексировать БД 7.7 !");
    V7=Ложь;
    Возврат;
    КонецЕсли;
    Состояние("База успешно открыта");

    СправочникНоменклатураТам = V7.CreateObject("Справочник.Номенклатура"); // справочник
    СправочникНоменклатураТам.ВыбратьЭлементы();

    Пока СправочникНоменклатураТам.ПолучитьЭлемент() = 1 Цикл
    Если СправочникНоменклатураТам.ПометкаУдаления() = 1 Тогда
    Продолжить;
    КонецЕсли;
    и.т.д..............
  3. Kirya
    Offline

    Kirya Опытный в 1С

    Регистрация:
    3 авг 2006
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Если из 77 в 8.0, то я делал так

    Код:
        База80=СоздатьОбъект("v8.Application");
    База80.Connect("Srvr=Server1c;Ref=Base1c");
    
    ВыборкаОрг=База80.Справочники.Организации.Выбрать(); 
    Пока ВыборкаОрг.Следующий()<>0 Цикл
    
    .........
    
    КонецЦикла;    
    
  4. TopicStarter Overlay
    alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Спасибо!!!! Заработало!!! :unsure:
Похожие темы
  1. Александр-Н
    Ответов:
    9
    Просмотров:
    1.070
Загрузка...

Поделиться этой страницей