8.х РОЗ Снятие отчета с банковского терминала оплаты карточками из Розницы

Тема в разделе ""1С:Розница"", создана пользователем rSlayer, 8 ноя 2011.

  1. TopicStarter Overlay
    rSlayer
    Offline

    rSlayer Опытный в 1С

    Регистрация:
    31 мар 2009
    Сообщения:
    251
    Симпатии:
    0
    Баллы:
    26
    Коллеги. Имеется 1с 8.1
    Розница версии 1.0.16.1
    Подключили Эквайринговую систему Сбербанка.
    На терминале нет печатающего устройства для отчета.
    Хотим отчет получить через 1С.
    Вроде бы в обработке обслеживания SberBankES_v2.epf вижу функцию "ИтогиДняПоКартам"
    Вызывается она при закрытии смены в 1С из обработки "ЗакрытиеКассовойСмены".
    Но вот сам данный функционал по печати этих итогов запрограммирован в проверку след.услуовия
    Код:
    ОткрыватьФорму = ОбработкаЗакрытиеККМ.ОпределитьВозможностьСверкиИтогов(НеопределенноеЗначение);
    
    Форма = ОбработкаЗакрытиеККМ.ПолучитьФорму();
    Если ОткрыватьФорму Тогда
    Форма.Открыть();
    Иначе
    Форма.КоманднаяПанельДействийЗакрытьСмену(НеопределенноеЗначение);
    КонецЕсли;
    
    
    Но вот в чем косяк, проверка возможности свертки итогов завершается с ошибкой, так как программа не может найти ID эквайринговой системы среди поддерживаемого ТО.
    А список поддерживаемого ТО формируется в обработке "МенюРМК" функцией "ПоддерживаетсяВидТО"

    Код:
    Функция ПоддерживаетсяВидТО(Вид) Экспорт
    
    Результат = Ложь;
    
    Если Вид = Перечисления.ВидыТорговогоОборудования.ФискальныйРегистратор
    Или Вид = Перечисления.ВидыТорговогоОборудования.ДисплейПокупателя Тогда
    Результат = Истина;
    КонецЕсли;
    
    Возврат Результат;
    
    КонецФункции // ПоддерживаетсяВидТО()
    
    
    И среди перечислений нет Эквайринговых систем.

    В чем фишка? Как получить отчет с банковского терминала карт?
  2. TopicStarter Overlay
    rSlayer
    Offline

    rSlayer Опытный в 1С

    Регистрация:
    31 мар 2009
    Сообщения:
    251
    Симпатии:
    0
    Баллы:
    26
    Никто не пользуется банк.терминалами что-ли?
  3. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    Подключить терминал параллельно и пользоваться универсальным отчетом.
  4. TopicStarter Overlay
    rSlayer
    Offline

    rSlayer Опытный в 1С

    Регистрация:
    31 мар 2009
    Сообщения:
    251
    Симпатии:
    0
    Баллы:
    26
    Ну автоматизация на то и автоматизация, чтобы все делалось автоматически. Если есть возможность подключить терминал к компьютеру, почему бы этого не сделать?
  5. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    Автоматизация не страдает при подключении параллельно. Появляется только необходимость нажатия кнопочки дополнительной. За то нет никаких проблем.

Поделиться этой страницей