8.х Склонение фамилий

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Alehan, 11 окт 2007.

  1. TopicStarter Overlay
    Alehan
    Offline

    Alehan

    Регистрация:
    6 сен 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    У меня в отчет выходят фамилии и должности сотрудников, например "директор Иванов А.А." Мне надо чтобы выводилось следующим образом "в лице директора Иванова А.А." Возможно ли так сделать?
  2. skvs
    Offline

    skvs

    Регистрация:
    1 окт 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    На любом ИТС есть компонента СклонениеФИО
  3. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    будьте любезны, поделитесь такой компонентой.
    имеется строгая необходимость сделать то же самое.
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Вот.

    Размещать в регистре сведений Внешние компаненты

    Чет нифига не ципляется наберите в инете может есть NameDecl.dll
  5. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    в папке bin лежит NameDecl.dll
    regsvr32 ее ))

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">[color=green]// Функция склоняет переданую фразу[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Фраза (обязательный), тип строка[/color]
    [color=green]//   Параметр должен содержать фразу. Каждое слово фразы будет просклонено отдельно[/color]
    [color=green]//[/color]
    [color=green]//  Падеж (обязательный), тип число[/color]
    [color=green]//   Падеж, в который необходимо поставить ФИО.[/color]
    [color=green]//   1 - Именительный[/color]
    [color=green]//   2 - Родительный[/color]
    [color=green]//   3 - Дательный[/color]
    [color=green]//   4 - Винительный[/color]
    [color=green]//   5 - Творительный[/color]
    [color=green]//   6 - Предложный[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> Просклонять[color=red]([/color]Компонента[color=red],[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Фраза [color=red]=[/color] [color=black]""[/color][color=red],[/color] Падеж [color=red]=[/color] [color=black]1[/color][color=red],[/color] Результат[color=red],[/color] Пол [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span>[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/экспорт')">Экспорт</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Компонента [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Результат [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    
    [color=brown]                #Если Клиент Тогда[/color]
    
    МассивСтрок [color=red]=[/color] ОбщегоНазначения[color=red].[/color]РазложитьСтрокуВМассивПодстрок[color=red]([/color]Фраза[color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">Для</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/каждого')">Каждого</span> СтрокаМассива <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/из')">Из</span> МассивСтрок <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПустаяСтрока[color=red]([/color]СтрокаМассива[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ФИОНаписаноПоРусски[color=red]([/color]СтрокаМассива[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Результат [color=red]+[/color] СтрокаМассива [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">Попытка</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Мужской <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Результат [color=red]+[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]СтрокаМассива[color=red],[/color] Падеж[color=red],[/color] [color=black]1[/color][color=red])[/color] [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Женский <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Результат [color=red]+[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]СтрокаМассива[color=red],[/color] Падеж[color=red],[/color] [color=black]2[/color][color=red])[/color] [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Результат [color=red]=[/color] Результат [color=red]+[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]СтрокаМассива[color=red],[/color] Падеж[color=red])[/color] [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">Исключение</span>
    Результат [color=red]=[/color] Фраза[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпопытки')">КонецПопытки</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    Результат [color=red]=[/color] СокрЛП[color=red]([/color]Результат[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span>[color=red];[/color]
    
    [color=brown]                #Иначе[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    
    [color=brown]                #КонецЕсли[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]// Просклонять()[/color]
    
    [color=green]// Функция склоняет ФИО[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  ФИО (обязательный), тип строка[/color]
    [color=green]//   Параметр должен содержать фамилию, имя и отчество в именительном падеже единственного числа.[/color]
    [color=green]//   Строка должна состоять только из букв русского алфавита, пробелов и дефисов. Фамилия, имя и отчество[/color]
    [color=green]//   должны разделяться пробелами. Внутри фамилии, имени, отчества пробелов быть не должно.[/color]
    [color=green]//   Допустимы следующие сочетания фамилии, имени и отчества: ФИО, ИОФ, ИО, ИФ, ФИ, Ф, И, О.[/color]
    [color=green]//   Двойные и тройные имена и фамилии должны писаться через дефис. Имена и отчества должны быть полные[/color]
    [color=green]//[/color]
    [color=green]//  Падеж (обязательный), тип число[/color]
    [color=green]//   Падеж, в который необходимо поставить ФИО.[/color]
    [color=green]//   1 - Именительный[/color]
    [color=green]//   2 - Родительный[/color]
    [color=green]//   3 - Дательный[/color]
    [color=green]//   4 - Винительный[/color]
    [color=green]//   5 - Творительный[/color]
    [color=green]//   6 - Предложный[/color]
    [color=green]//[/color]
    [color=green]//  Пол (необязательный), тип ПеречислениеСсылка.ПолФизическихЛиц[/color]
    [color=green]//   Данный параметр предназначен для разрешения возможных неоднозначностей, например, имя Карен Акопян[/color]
    [color=green]//   может принадлежать и мужчине, и женщине, и в зависимости от этого склоняться или не склоняться.[/color]
    [color=green]//   В остальных случаях рекомендуется опускать этот параметр.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ПросклонятьФИО[color=red]([/color]Компонента[color=red],[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> ФИО [color=red]=[/color] [color=black]""[/color][color=red],[/color] Падеж [color=red]=[/color] [color=black]1[/color][color=red],[/color] Пол [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span>[color=red],[/color] Результат [color=red]=[/color] [color=black]""[/color][color=red],[/color] СообщениеОбОшибке [color=red]=[/color] [color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/экспорт')">Экспорт</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Компонента [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Результат [color=red]=[/color] ФИО[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПустаяСтрока[color=red]([/color]ФИО[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Строка с ФИО не должна быть пустой."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не</span> ФИОНаписаноПоРусски[color=red]([/color]ФИО[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Строка с ФИО должна состоять только из букв русского алфавита, пробелов и дефисов."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СтрЧислоВхождений[color=red]([/color]ФИО[color=red],[/color] [color=black]" "[/color][color=red])[/color] [color=red]>[/color] [color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Фамилия, имя и отчество должны разделяться пробелами. Внутри фамилии, имени и отчества пробелов быть не должно."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    [color=brown]                #Если Клиент Тогда[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">Попытка</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Мужской <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Женский <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red],[/color] [color=black]2[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">Исключение</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпопытки')">КонецПопытки</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span>[color=red];[/color]
    
    [color=brown]                #Иначе[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    
    [color=brown]                #КонецЕсли[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]// ПросклонятьФИО()[/color]
    
    [color=green]// Функция склоняет Фамилию, Имя и Отчество[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Фамилия, Имя, Отчество (обязательный), тип строка[/color]
    [color=green]//   Параметры должены содержать фамилию, имя и отчество в именительном падеже единственного числа.[/color]
    [color=green]//   Строка должна состоять только из букв русского алфавита, пробелов и дефисов. [/color]
    [color=green]//   Внутри фамилии, имени, отчества пробелов быть не должно.[/color]
    [color=green]//   Двойные и тройные имена и фамилии должны писаться через дефис. Имена и отчества должны быть полные[/color]
    [color=green]//[/color]
    [color=green]//  Падеж (обязательный), тип число[/color]
    [color=green]//   Падеж, в который необходимо поставить ФИО.[/color]
    [color=green]//   1 - Именительный[/color]
    [color=green]//   2 - Родительный[/color]
    [color=green]//   3 - Дательный[/color]
    [color=green]//   4 - Винительный[/color]
    [color=green]//   5 - Творительный[/color]
    [color=green]//   6 - Предложный[/color]
    [color=green]//[/color]
    [color=green]//  Пол (необязательный), тип ПеречислениеСсылка.ПолФизическихЛиц[/color]
    [color=green]//   Данный параметр предназначен для разрешения возможных неоднозначностей, например, имя Карен Акопян[/color]
    [color=green]//   может принадлежать и мужчине, и женщине, и в зависимости от этого склоняться или не склоняться.[/color]
    [color=green]//   В остальных случаях рекомендуется опускать этот параметр.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ПросклонятьФамилиюИмяОтчество[color=red]([/color]Компонента[color=red],[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Фамилия [color=red]=[/color] [color=black]""[/color][color=red],[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Имя [color=red]=[/color] [color=black]""[/color][color=red],[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Отчество [color=red]=[/color] [color=black]""[/color][color=red],[/color] Падеж [color=red]=[/color] [color=black]1[/color][color=red],[/color] Пол [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span>[color=red],[/color] Результат [color=red]=[/color] [color=black]""[/color][color=red],[/color] СообщениеОбОшибке [color=red]=[/color] [color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/экспорт')">Экспорт</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Компонента [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    ФамилияНовая               [color=red]=[/color] Фамилия[color=red];[/color]
    ИмяНовое                         [color=red]=[/color] Имя[color=red];[/color]
    ОтчествоНовое              [color=red]=[/color] Отчество[color=red];[/color]
    
    Результат [color=red]=[/color] Фамилия [color=red]+[/color] [color=black]" "[/color] [color=red]+[/color] Имя [color=red]+[/color] [color=black]" "[/color] [color=red]+[/color] Отчество[color=red];[/color]
    
    [color=green]// Двойные и тройные ФИО, если указаны с пробелами, исправим на использование дефиса[/color]
    НужноИсправитьФамилию      [color=red]=[/color] Найти[color=red]([/color]Фамилия[color=red],[/color] [color=black]" "[/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color][color=red];[/color]
    НужноИсправитьИмя                 [color=red]=[/color] Найти[color=red]([/color]Имя[color=red],[/color] [color=black]" "[/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color][color=red];[/color]
    НужноИсправитьОтчество       [color=red]=[/color] Найти[color=red]([/color]Отчество[color=red],[/color] [color=black]" "[/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьФамилию <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ФамилияНовая [color=red]=[/color] СтрЗаменить[color=red]([/color]Фамилия[color=red],[/color] [color=black]" "[/color][color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьИмя <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяНовое [color=red]=[/color] СтрЗаменить[color=red]([/color]Имя[color=red],[/color] [color=black]" "[/color][color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьОтчество <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОтчествоНовое [color=red]=[/color] СтрЗаменить[color=red]([/color]Отчество[color=red],[/color] [color=black]" "[/color][color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    ФИО [color=red]=[/color] ФамилияНовая [color=red]+[/color] [color=black]" "[/color] [color=red]+[/color] ИмяНовое [color=red]+[/color] [color=black]" "[/color] [color=red]+[/color] ОтчествоНовое[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПустаяСтрока[color=red]([/color]ФИО[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Строка с ФИО не должна быть пустая."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не</span> ФИОНаписаноПоРусски[color=red]([/color]ФИО[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Строка с ФИО должна состоять только из букв русского алфавита, пробелов и дефисов."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СтрЧислоВхождений[color=red]([/color]ФИО[color=red],[/color] [color=black]" "[/color][color=red])[/color] [color=red]>[/color] [color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СообщениеОбОшибке [color=red]=[/color] [color=black]"Фамилия, имя и отчество должны разделяться пробелами. Внутри фамилии, имени, отчества пробелов быть не должно."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    [color=brown]                #Если Клиент Тогда[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">Попытка</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Мужской <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Пол [color=red]=[/color] Перечисления[color=red].[/color]ПолФизическихЛиц[color=red].[/color]Женский <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red],[/color] [color=black]2[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Результат [color=red]=[/color] Компонента[color=red].[/color]Просклонять[color=red]([/color]ФИО[color=red],[/color] Падеж[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    [color=green]// Вернем пробелы в составные ФИО обратно, если до этого их изменили[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьФамилию <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> НужноИсправитьИмя <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> НужноИсправитьОтчество <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    МассивФИО [color=red]=[/color] ОбщегоНазначения[color=red].[/color]РазложитьСтрокуВМассивПодстрок[color=red]([/color]Результат[color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    
    Результат [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    
    ИндексФИО [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не</span> ПустаяСтрока[color=red]([/color]Фамилия[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ФамилияНовая [color=red]=[/color] МассивФИО[color=red][[/color]ИндексФИО[color=red]][/color][color=red];[/color]
    ИндексФИО [color=red]=[/color] ИндексФИО [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьФамилию <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СтрЧислоВхождений[color=red]([/color]Фамилия[color=red],[/color] [color=black]"-"[/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    МассивФамилия [color=red]=[/color] ОбщегоНазначения[color=red].[/color]РазложитьСтрокуВМассивПодстрок[color=red]([/color]ФамилияНовая[color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    ФамилияНовая [color=red]=[/color] МассивФамилия[color=red][[/color][color=black]0[/color][color=red]][/color][color=red];[/color]
    ИндексФамилия [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    ПозПробел [color=red]=[/color] Найти[color=red]([/color]Фамилия[color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    ПозДефис  [color=red]=[/color] Найти[color=red]([/color]Фамилия[color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПозПробел [color=red]=[/color] ПозДефис <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/прервать')">Прервать</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]ПозДефис [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> [color=red]([/color]ПозПробел [color=red]>[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]ПозПробел [color=red]<[/color] ПозДефис[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ФамилияНовая [color=red]=[/color] ФамилияНовая [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    Фамилия [color=red]=[/color] Сред[color=red]([/color]Фамилия[color=red],[/color] ПозПробел[color=red]+[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> [color=red]([/color]ПозПробел [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> [color=red]([/color]ПозДефис [color=red]>[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]ПозДефис [color=red]<[/color] ПозПробел[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ФамилияНовая [color=red]=[/color] ФамилияНовая [color=red]+[/color] [color=black]"-"[/color][color=red];[/color]
    Фамилия [color=red]=[/color] Сред[color=red]([/color]Фамилия[color=red],[/color] ПозДефис[color=red]+[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    ФамилияНовая [color=red]=[/color] ФамилияНовая [color=red]+[/color] МассивФамилия[color=red][[/color]ИндексФамилия[color=red]][/color][color=red];[/color]
    ИндексФамилия [color=red]=[/color] ИндексФамилия [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ФамилияНовая [color=red]=[/color] СтрЗаменить[color=red]([/color]ФамилияНовая[color=red],[/color] [color=black]"-"[/color][color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Результат [color=red]=[/color] Результат [color=red]+[/color] ФамилияНовая[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не</span> ПустаяСтрока[color=red]([/color]Имя[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяНовое [color=red]=[/color] МассивФИО[color=red][[/color]ИндексФИО[color=red]][/color][color=red];[/color]
    ИндексФИО [color=red]=[/color] ИндексФИО [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НужноИсправитьИмя <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СтрЧислоВхождений[color=red]([/color]Имя[color=red],[/color] [color=black]"-"[/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    МассивИмя [color=red]=[/color] ОбщегоНазначения[color=red].[/color]РазложитьСтрокуВМассивПодстрок[color=red]([/color]ИмяНовое[color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    ИмяНовое [color=red]=[/color] МассивИмя[color=red][[/color][color=black]0[/color][color=red]][/color][color=red];[/color]
    ИндексИмя [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    ПозПробел [color=red]=[/color] Найти[color=red]([/color]Имя[color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    ПозДефис  [color=red]=[/color] Найти[color=red]([/color]Имя[color=red],[/color] [color=black]"-"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПозПробел [color=red]=[/color] ПозДефис <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/прервать')">Прервать</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]ПозДефис [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> [color=red]([/color]ПозПробел [color=red]>[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]ПозПробел [color=red]<[/color] ПозДефис[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяНовое [color=red]=[/color] ИмяНовое [color=red]+[/color] [color=black]" "[/color][color=red];[/color]
    Имя [color=red]=[/color] Сред[color=red]([/color]Имя[color=red],[/color] ПозПробел[color=red]+[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> [color=red]([/color]ПозПробел [color=red]=[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> [color=red]([/color]ПозДефис [color=red]>[/color] [color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]ПозДефис [color=red]<[/color] ПозПробел[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяНовое [color=red]=[/color] ИмяНовое [color=red]+[/color] [color=black]"-"[/color][color=red];[/color]
    Имя [color=red]=[/color] Сред[color=red]([/color]Имя[color=red],[/color] ПозДефис[color=red]+[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    ИмяНовое [color=red]=[/color] ИмяНовое [color=red]+[/color] МассивИмя[color=red][[/color]ИндексИмя[color=red]][/color][color=red];[/color]
    ИндексИмя [color=red]=[/color] ИндексИмя [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ИмяНовое [color=red]=[/color] СтрЗаменить[color=red]([/color]ИмяНовое[color=red],[/color] [color=black]"-"[/color][color=red],[/color] [color=black]" "[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Результат [color=red]=[/color] СокрЛП[color=red]([/color]Результат [color=red]+[/color] [color=black]" "[/color] [color=red]+[/color] ИмяНовое[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не</span> ПустаяСтрока[color=red]([/color]Отчество[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОтчествоНовое [color=red]=[/color] МассивФИО[color=red][[/color]ИндексФИО[color=red]][/color][color=red];[/color]
  6. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    ребят, выложите пожалуйста саму dll - NameDecl.dll, нигде не могу найти.
  7. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    у тебя типовая конфигурация есть?
  8. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    вот

    Вложения:

    • NameDecl.rar
      Размер файла:
      137,4 КБ
      Просмотров:
      1.543
  9. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    tirk
    спасибо большое!
    буду разбираться!!!
  10. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    не получается подключить её. помогите пожалуйста!!!
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Библу регестрировали в системе?
  12. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    конечно! каким образом её подключить в 1с и как её использовать???
  13. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Заработало!
    Код:
    	Попытка
    ПодключитьВнешнююКомпоненту("AddIn.NameDecl");
    //	Сообщить("Компонента подключена");
    Исключение Сообщить("Не удалось загрузить внешнюю компоненту" + ОписаниеОшибки());
    КонецПопытки;
    Функ = Новый ("AddIn.NameDeclension"); 
    склонение = Функ.Просклонять("Фамилия",2);
    //третий параметр пол, с ним не разобрался, принимает значения 0, 1, 2
    
  14. 4el
    Offline

    4el

    Регистрация:
    18 янв 2010
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    блииин, ужасно криво склоняет должности(составные)!
    или этот модуль не используется для склонения должностей?!?
    ЗЫ: например такие как "руководитель отдела, заместитель директора, начальник отдела кадров"
  15. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Да такие плохо склоняет. А пользователям кк всегда н еохото ручками поправлять? Напишите внешние печатные формы...
  16. gauss
    Offline

    gauss

    Регистрация:
    8 дек 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Не подскажите как 1с вообще отучить склонять фамилии?
  17. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Заставить ее не подключать внешнюю компоненту))))))))))))
  18. inoks
    Offline

    inoks

    Регистрация:
    31 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1

Поделиться этой страницей