8.х СКД. Надпись "Отчет формируется" и картинка при формировании отчета в управляемой форме.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Assembler, 12 сен 2011.

  1. TopicStarter Overlay
    Assembler
    Offline

    Assembler

    Регистрация:
    12 сен 2011
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Управляемая форма.
    Как вытащить при программном формировании отчета надпись "Отчет формируется..." и картинку? У меня клиент-серверный вариант режима работы системы 1С:Предприятие 8.2.

    Ниже код:
    &НаСервере
    Процедура Скомпоновать()
    ЭтаФорма.АвтоОтображениеСостояния = РежимАвтоОтображенияСостояния.Отображать;
    ЭтаФорма.СкомпоноватьРезультат(РежимКомпоновкиРезультата.Фоновый); //ФОНОВЫЙ!!!!!!!!!!!
    КонецПроцедуры //Скомпоновать()

    Примечание: Для Таб. док. "Результат" при смене варианта, тоже программным способом я вывожу:
    Элементы.Результат.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
    Элементы.Результат.ОтображениеСостояния.Текст = "Отчет не сформирован. Нажмите ""Сформировать"" для получения отчета.";
    Элементы.Результат.ОтображениеСостояния.Видимость = Истина;
  2. TopicStarter Overlay
    Assembler
    Offline

    Assembler

    Регистрация:
    12 сен 2011
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Сам программный вывод отчета осуществяется в модуле объекта в процедуре ПрикомпоновкеРезультата().
  3. TopicStarter Overlay
    Assembler
    Offline

    Assembler

    Регистрация:
    12 сен 2011
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    &НаСервере
    Процедура Скомпоновать()
    ЭтаФорма.СкомпоноватьРезультат(РежимКомпоновкиРезультата.Фоновый);
    КонецПроцедуры //Скомпоновать()

    &НаКлиенте
    Процедура Сформировать(Команда)
    // Вставить содержимое обработчика.

    ВыбраннаяКартинка = БиблиотекаКартинок.ДлительнаяОперация48;
    Элементы.Результат.ОтображениеСостояния.Картинка = ВыбраннаяКартинка;

    Элементы.Результат.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
    Элементы.Результат.ОтображениеСостояния.Текст = "Отчет формируется...";
    Элементы.Результат.ОтображениеСостояния.Видимость = Истина;

    Скомпоновать();

    КонецПроцедуры


    Но, почему-то компоновка протекает не в фоновом режиме и картинка не анимированная, хотя ВыбраннаяКартинка.Формат() = GIF

Поделиться этой страницей