8.х Синтактическая ошибка.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем alexburn, 3 апр 2009.

  1. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Есть код:
    Код:
    Запрос.Текст=Запрос.Текст + "И НоменклатураРодитель=&Группа";
    Запрос.УстановитьПараметр("Группа",ЭлементыФормы.Группа.Значение);
    
    Выдает ошибку:
    Не могу понять, что сделал не так :unsure:
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    ОШИБКА тут
    НоменклатураРодитель**ошибка**И НоменклатураРодитель<<?>>=&Группа

    т.е. пробела нет между синтаксисом

    и вообще не понятно что там за условие*??? потому как неясно зачем и?? Т.е. скинь условие полностью или запрос... если что то непонятно будет
  3. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вот что просили:
    Код:
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Наименование,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код КАК НоменклатураКод,
    |    СерииНоменклатуры.СрокГодности,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель КАК НоменклатураРодитель,
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток,
    |    ПартииТоваровНаСкладахОстатки.СтоимостьОстаток
    |ИЗ
    |    РегистрНакопления.ПартииТоваровНаСкладах.Остатки КАК ПартииТоваровНаСкладахОстатки
    |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СерииНоменклатуры КАК СерииНоменклатуры
    |        ПО ПартииТоваровНаСкладахОстатки.СерияНоменклатуры = СерииНоменклатуры.Ссылка
    |ГДЕ
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток > 0
    |
    |УПОРЯДОЧИТЬ ПО
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель.Наименование ВОЗР,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код ВОЗР
    |ИТОГИ ПО
    |    НоменклатураРодитель";
    
    Если ЭлементыФормы.Группа.Значение=Справочники.Номенклатура.ПустаяСсылка() Тогда
    Сообщить("Группа пустая");
    Иначе
    Запрос.Текст=Запрос.Текст + "И НоменклатураРодитель = &Группа";
    Запрос.УстановитьПараметр("Группа",ЭлементыФормы.Группа.Значение);
    КонецЕсли;
    
    Результат = Запрос.Выполнить();
    
    
  4. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    у тебя когда поле Группа пустое тогда выдает ошибку... потому как запрос не останавливаешь а с пустым параметром.....и как ты условие туда вставляешь)))???

    Код:
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Наименование,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код КАК НоменклатураКод,
    |    СерииНоменклатуры.СрокГодности,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель КАК НоменклатураРодитель,
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток,
    |    ПартииТоваровНаСкладахОстатки.СтоимостьОстаток
    |ИЗ
    |    РегистрНакопления.ПартииТоваровНаСкладах.Остатки КАК ПартииТоваровНаСкладахОстатки
    |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СерииНоменклатуры КАК СерииНоменклатуры
    |        ПО ПартииТоваровНаСкладахОстатки.СерияНоменклатуры = СерииНоменклатуры.Ссылка
    |ГДЕ
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток > 0 ";
    Если ЗначениеЗаполнено( ЭлементыФормы.Группа.Значение) Тогда
    
    Запрос.Текст = Запрос.текст + " И НоменклатураРодитель = &Группа ";
    Запрос.УстановитьПараметр("Группа",ЭлементыФормы.Группа.Значение);
    КонецЕсли;
    Запрос.Текст = Запрос.текст + " 
    |
    |УПОРЯДОЧИТЬ ПО
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель.Наименование ВОЗР,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код ВОЗР
    |ИТОГИ ПО
    |    НоменклатураРодитель";
    
    Если ЭлементыФормы.Группа.Значение=Справочники.Номенклатура.ПустаяСсылка() Тогда
    Сообщить("Группа пустая");
    Иначе
    Запрос.Текст=Запрос.Текст + "И НоменклатураРодитель = &Группа";
    Запрос.УстановитьПараметр("Группа",ЭлементыФормы.Группа.Значение);
    КонецЕсли;
    
    Результат = Запрос.Выполнить();
    
    
    
    
  5. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вот рабочий код:
    Код:
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Наименование,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код КАК НоменклатураКод,
    |    СерииНоменклатуры.СрокГодности,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель КАК НоменклатураРодитель,
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток,
    |    ПартииТоваровНаСкладахОстатки.СтоимостьОстаток
    |ИЗ
    |    РегистрНакопления.ПартииТоваровНаСкладах.Остатки КАК ПартииТоваровНаСкладахОстатки
    |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СерииНоменклатуры КАК СерииНоменклатуры
    |        ПО ПартииТоваровНаСкладахОстатки.СерияНоменклатуры = СерииНоменклатуры.Ссылка
    |ГДЕ
    |    ПартииТоваровНаСкладахОстатки.КоличествоОстаток > 0";
    Если Не ЗначениеНеЗаполнено(ЭлементыФормы.Группа.Значение) Тогда
    Запрос.Текст=Запрос.Текст + " И ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель = &Группа";
    Запрос.УстановитьПараметр("Группа",ЭлементыФормы.Группа.Значение);
    КонецЕсли;
    Запрос.Текст=Запрос.Текст + "
    |
    |УПОРЯДОЧИТЬ ПО
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Родитель.Наименование ВОЗР,
    |    ПартииТоваровНаСкладахОстатки.Номенклатура.Код ВОЗР
    |ИТОГИ ПО
    |    НоменклатураРодитель";
    
    Результат = Запрос.Выполнить();
    
    
    Можно закрывать тему.
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.372
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.049
Загрузка...

Поделиться этой страницей