8.х Штрихкод вместо артикула в ТОРГ12

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mazahaka-7, 20 июл 2016.

  1. TopicStarter Overlay
    mazahaka-7
    Offline

    mazahaka-7

    Регистрация:
    20 июл 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    Подскажите, пожалуйста, как можно реализовать замену поля "артикул" на "штрихкод" (из карточки товара) в накладной ТОРГ12?

    Или же, можно попробовать написать процедуру, которая заменит артикулы на штрихкоды.

    Есть база на 900 товаров, вручную менять не сильно хотелось бы.

    Нашел такую процедуру на форуме:
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
        НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
        НаборЗаписей.Прочитать();
        Для Каждого Запись Из НаборЗаписей Цикл
            Если ЗначениеЗаполнено(Запись.Штрихкод) Тогда
                //тут нужно выбрать товар из Справочники.Номенклатура по коду
                //заменить поле артикул на штрихкод
                //сохранить :)
            КонецЕсли;
        КонецЦикла;
        НаборЗаписей.Записать();
    КонецПроцедуры
    С 1С-кой только начал знакомиться, так что буду рад любой помощи. Благодарю)
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Начнем с того, что вы уверены, что ШК влезет в поле Артикул?
  3. TopicStarter Overlay
    mazahaka-7
    Offline

    mazahaka-7

    Регистрация:
    20 июл 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Да, вручную заполняется корректно
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    В таком случае воспользуйтесь выборкой из регистра сведений/запросом выберите все записи из регистра сведений.
    Объект номенклатуры получите из ссылки.
  5. TopicStarter Overlay
    mazahaka-7
    Offline

    mazahaka-7

    Регистрация:
    20 июл 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Простите, а как это сделать?
    Есть информация по этому поводу, которую можно почитать?
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Если вы планируете развиваться в направлении 1С, то как минимум книжки Радченко по программированию 1С, например.
  7. TopicStarter Overlay
    mazahaka-7
    Offline

    mazahaka-7

    Регистрация:
    20 июл 2016
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Благодарю

Поделиться этой страницей