7.7 ШК Symbol LS 2208 Кто ставил?

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем oleg2004111, 2 дек 2010.

  1. TopicStarter Overlay
    oleg2004111
    Offline

    oleg2004111

    Регистрация:
    1 май 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    ШК Symbol LS 2208 Кто ставил?


    моя 7,7 торговля склад
    конфа
    говорит: НЕ УДАЛОСЬ подключить сканер штрих-кода!!! ставлю RS 232

    помогите разобраться с настройками

    [​IMG]
  2. TopicStarter Overlay
    oleg2004111
    Offline

    oleg2004111

    Регистрация:
    1 май 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Если я правильно понимаю нада писать переменную для сканера?
  3. Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    а что предпринималось для подключения??
  4. TopicStarter Overlay
    oleg2004111
    Offline

    oleg2004111

    Регистрация:
    1 май 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    стандартная настройка оборудования с указанием рабочего компа и способ подключения рс 232
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Возьмите стандатный монитор с сайта Штрих-М и проверьте работоспособность.
    Может самое банальное- не работает СОМ порт или вы указали не ту скорость. Выставлять нужно ту скорость которая отобразилась при поиске оборудования
  6. TopicStarter Overlay
    oleg2004111
    Offline

    oleg2004111

    Регистрация:
    1 май 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Конфа внешнее событие распознает но штрих код определяет как "0"


    Процедура глУстановкаШтрихКода(Конт,Данные) Экспорт
    // Разбор строки данных от сканера штрих кода - определение формата штрих-кода
    Если ШтрихКодИмеетПрефикс=1 Тогда
    Если Найти("MPJS",Лев(Данные,1))=0 Тогда
    Предупреждение("Формат считанного штрих-кода не предназначен для товаров.");
    Возврат;
    Иначе
    Данные=Сред(Данные,2,СтрДлина(Данные)-1);
    КонецЕсли;
    КонецЕсли;
    // Запись полученного штрих-кода
    Если ПустоеЗначение(Конт.ШтрихКод)=1 Тогда
    Конт.ШтрихКод=Число(Данные);
    Иначе
    Если Вопрос("Штрих-код уже задан. Переписать?", 4 )=6 Тогда
    Конт.ШтрихКод=Число(Данные);
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры


    Почеиу?

Поделиться этой страницей