[РЕШЕНО] Сформировать заголовок во внешней форме

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем lilluminna, 15 июн 2015.

  1. TopicStarter Overlay
    lilluminna
    Offline

    lilluminna

    Регистрация:
    15 июн 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Я совсем совсем не программист, нарисовала очень простенькую форму печати и не могу совладать с заголовком. Мне на печать необходимо вывести как в стандартных печатных формах-название документа номер и дата (но это название формы но не на печать должно идти). И при отправки на майл должен сформироваться такой же заголовок.
    Код:
    Функция Печать() Экспорт
    
        Макет = ПолучитьМакет("Макет");
        ТабДокумент = Новый ТабличныйДокумент;
        Область2 = Макет.ПолучитьОбласть("Заголовок");
        ТабДокумент.Вывести(Область2);
        Область = Макет.ПолучитьОбласть("Строка");
        Для Каждого ТекЭлемент Из СсылкаНаОбъект.Товары Цикл
            Область.Параметры.Код = ТекЭлемент.Номенклатура.Код;
            Область.Параметры.Артикул = ТекЭлемент.Номенклатура.Артикул;
            Область.Параметры.Наименование = ТекЭлемент.Номенклатура.Наименование;
            Область.Параметры.Количество = ТекЭлемент.Количество;
            ТабДокумент.Вывести(Область);
        КонецЦикла;
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент);
        
    КонецФункции
    
  2. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Код:
    Функция Печать() Экспорт
    
        Макет = ПолучитьМакет("Макет");
        ТабДокумент = Новый ТабличныйДокумент;
        Область2 = Макет.ПолучитьОбласть("Заголовок");
        ТабДокумент.Вывести(Область2);
        Область = Макет.ПолучитьОбласть("Строка");
        Для Каждого ТекЭлемент Из СсылкаНаОбъект.Товары Цикл
            Область.Параметры.Код = ТекЭлемент.Номенклатура.Код;
            Область.Параметры.Артикул = ТекЭлемент.Номенклатура.Артикул;
            Область.Параметры.Наименование = ТекЭлемент.Номенклатура.Наименование;
            Область.Параметры.Количество = ТекЭлемент.Количество;
            ТабДокумент.Вывести(Область);
        КонецЦикла;
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент,,,"Номер документа "+СсылкаНаОбъект.Номер+ " от "+СсылкаНаОбъект.Дата);
      
    КонецФункции
  3. TopicStarter Overlay
    lilluminna
    Offline

    lilluminna

    Регистрация:
    15 июн 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Вы Гений спасибо большое. Все получилось :)

Поделиться этой страницей