8.х СФ выданный на основании ТОРГ12

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем dim3740, 17 апр 2011.

  1. TopicStarter Overlay
    dim3740
    Offline

    dim3740 Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    93
    Симпатии:
    0
    Баллы:
    26
    Добрый день! При восстановлении учета в типовой бухне 8.1 оператор ввел много документов реализации. Нужна внешняя обработка, которая сформирует в базе выданные СФ. Думаю, что нужно обратиться к форме дока реализации и выполнить там процедуру ГиперссылкаСчетФактураНажатие, и потом автоматом закрыть обе формы. Как? Заранее спасибо.
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Пишите редакцию бухгалтерии
  3. TopicStarter Overlay
    dim3740
    Offline

    dim3740 Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    93
    Симпатии:
    0
    Баллы:
    26
    Ответ не слишком обнадеживающий....
    К примеру, меня устроит в процедуре "ПриОткрытии" дока прописать (потом удалю)ГиперссылкаСчетФактураНажатие(ЭтотОбъект); Это уже лучше - автоматом открывается модальное СФ, и заполняется реквизиты СФ.
    Ну и дальше: неужели нельзя применить нечто такого кода в обработке? Каковы причины?:
    Выборка=Документы.РеализацияТоваровУслуг.Выбрать(НачПериода,КонПериода);
    Пока Выборка.Следующий() Цикл
    ОбъектВыборка=Выборка.ПолучитьОбъект();
    ФормаДока=ОбъектВыборка.ПолучитьФорму();
    ФормаДока.Открыть();
    ФормаДока.Закрыть();
    ОбъектВыборка.Записать(РежимЗаписиДокумента.Проведение);
    КонецЦикла;
  4. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Вполне себе адекватный ответ. Бухгалтерия 1.6 и Бухгалтерия 2.0 отличаются весьма и весьма :)
    Зачем конфу править ради этого? Пишите внешнюю обработку. И формы вовсе незачем открывать, всё можно сформировать программно.
    Код:
    Пока Выборка.Следующий() Цикл 
    СчФ = Документы.СчетФактураВыданный.СоздатьДокумент();
    СчФ.Дата = Выборка.Дата;
    СчФ.Заполнить(Выборка.Ссылка); 
    СчФ.Записать(РежимЗаписиДокумента.Проведение);
    Сообщить("Создан документ " + СчФ); 
    КонецЦикла;
    
  5. TopicStarter Overlay
    dim3740
    Offline

    dim3740 Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    93
    Симпатии:
    0
    Баллы:
    26
    Зачем конфу править ради этого? Пишите внешнюю обработку. И формы вовсе незачем открывать, всё можно сформировать программно.
    Код:
    Пока Выборка.Следующий() Цикл 
    СчФ = Документы.СчетФактураВыданный.СоздатьДокумент();
    СчФ.Дата = Выборка.Дата;
    СчФ.Заполнить(Выборка.Ссылка); 
    СчФ.Записать(РежимЗаписиДокумента.Проведение);
    Сообщить("Создан документ " + СчФ); 
    КонецЦикла;
    
    
    Спасибо. Метод Заполнить в данном случае попробую. Хотя в других случаях, хотелось бы уметь все же передавать управление процедурам формы из внешних обработок. Пишут, что только ВК в 7-ке. А в 8-ке? Редакция 2.0 с недавних пор.

    Ох... После не совсем "мягкого" ответа на другом форуме, что, дескать, "это вообще невозможно", я решил, что мне предлагают с нуля написать свою новую редакцию :angry: Мои извинения, mialord.

Поделиться этой страницей