8.х Сетевой маркетинг

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем pengo, 22 фев 2008.

  1. TopicStarter Overlay
    pengo
    Offline

    pengo

    Регистрация:
    22 фев 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Всем доброе время суток!

    Вот решил с помощью 1С-ки автоматизировать работу организации, которая занимается сетевым маркетингом (МЛМ). Работает компания следующим образом. Под организацию подписываются люди, которые в свою очередь приводят других людей, тем самым выстраивая дерево сотрудников. Каждый из так называемых сотрудников приобретает товары, зарабатывая этими покупками баллы для себя и вышестоящих спонсоров. У компании существует маркетинг план, в соответствии с которым сотрудники получают вознаграждения за набранные балы. В общем всё стандартно для таких компаний, но реализацию подобного на 1С 8 я не нашёл.
    Подскажите, как правильно организовать структуру конфигурации, хотябы на начальном этапе (дальше уже и сам постараюсь разобраться). Возможно ли использование стандартных конфигураций? Если да, то каких, и будет ли их использование оправдано, может лучше написать с нуля?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Дык а что от конфы надо? Учет того, сколько контора должна каждому в дереве или что? Учет черный?
  3. TopicStarter Overlay
    pengo
    Offline

    pengo

    Регистрация:
    22 фев 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Да, нужно зать, сколько контора должна каждому в дереве (в зависимости от его ранга, уровня, но это уже алгоритмы, которые постараюсь описать сам). Учёт белый, хотя мне как новичку не совсем понятно, чем конфа может отличаться для белого и чёрного учётов. Если нетрудно, разъясните и этот момент.
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Pengo,
    1. Учет по дереву элементарен - храним владельна, при движении смотрим владельца, начисляем ему сумму по алгоритму, смотрим владельца этого владельца и т.д. (простая рекурсия)
    2. Черный учет не предполагает отчетности для налоговой, например. Соответственно, задача существенно упрощается.
  5. TopicStarter Overlay
    pengo
    Offline

    pengo

    Регистрация:
    22 фев 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    это я понимаю, а вот как правильно по этой схеме организовать структуру конфигурации, не знаю. Где, например хранить владельца, в справочнике или в документе его тоже нужно записывать? И так далее. Ну не доходит до меня (пока), как строить конфигурацию на основании имеющейся задачи :unsure:
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Pengo,
    Да нет - в документе хранить владельца не надо, такой реквизит нужно хранить или в РС или в самом справочнике.
    Честно говоря, глубоко не вникал, ибо надо еще хранить процент отката...

    ЗЫ. Да, наверное, все-таки, делать надо в РС - надо построить в нём дерево и с ним работать. принцип обхода дерева достаточно простой, поэтому сразу выйдешь на рекурсию.
  7. TopicStarter Overlay
    pengo
    Offline

    pengo

    Регистрация:
    22 фев 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Пока что единственный вопрос. Что такое РС - регистры сведений?
  8. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ну, вообще-то, в справке написано :)
  9. iii1
    Offline

    iii1

    Регистрация:
    17 июн 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Мы в свое время разработали решение для МЛМ, на базе УТ, потом интегрировали его с интернет-магазином. Если есть желание, напиши в личку.
  10. dimitriy
    Offline

    dimitriy

    Регистрация:
    13 мар 2012
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    меня данная тема интересует, написал в ЛС
  11. wolf3d
    Offline

    wolf3d Опытный в 1С

    Регистрация:
    5 мар 2011
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    в принципе от делать нечего на работе навскидку примерно такое:

    допустим каждый ВЫШЕСТОЯЩИЙ в дереве от текущего клиента получает +1 балл за покупку нижестоящими, тогда

    создаем справочник клиенты
    реквизиты - Наименование (тут имя клиента),КоличествоБаллов (тип число) и Владелец(тип справочники.Клиенты)

    создаем какой нить документ тпа Покупки
    в нем реквизит - клиент(справочники.Клиенты), ЧтоКупил и тд

    при проведении обрабатываем:

    Код:
    Процедура ПриПроведении
    перем вв;
    // проверяем - является ли клиент "самым верхним" в дереве
    вв="";
    вв1=неопределено;
    Если пустаястрока(сокрлп(клиент.владелец.наименование)) = ложь тогда
    вв1=клиент.владелец.получитьобьект();
    вв=вв1.наименование;
    КонецЕсли;
    
    пока пустаястрока(сокрлп(вв)) = ложь цикл
    вв1.КоличествоБаллов = вв1.КоличествоБаллов +1;
    вв1.записать();
    вв1=вв1.владелец.получитьобьект();
    вв=вв1.наименование;
    КонецЦикла;
    КонецПроцедуры
    
    это навскидку

Поделиться этой страницей