7.7 Себестоимость

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Asmodey, 31 окт 2008.

  1. TopicStarter Overlay
    Asmodey
    Offline

    Asmodey

    Регистрация:
    31 окт 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Прошу помочь.

    Где искать программный код распределения, указанных в документение ПоступлениеДопРасходы, сумм на себестоимость наменклатуры документа основания?

    Взаранее благодарен.
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Если в Комплексной, то в Конфигураторе ПоступлениеДопРасходы. Модуль документа.
  3. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    хороший вопрос. Ищи его в программе.
  4. TopicStarter Overlay
    Asmodey
    Offline

    Asmodey

    Регистрация:
    31 окт 2008
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Извините, а есть возможность выбирать товары на себестоимости которых должна распределятся сумма доп.расходов? ИЛИ вообще возможно такое организовать, просто я посмотрел там распределяется на сумму партии а не по наменклатурам отдельно.
  5. balabyt
    Offline

    balabyt

    Регистрация:
    14 авг 2006
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Распределить()
    ИтогоДопРасходов = ПолучитьИтогВРабВалюте();
    Если КоличествоСтрок()=0 Тогда
    Возврат;
    ИначеЕсли КоличествоСтрок()=1 Тогда
    ПолучитьСтрокуПоНомеру(1);
    СуммаПриходаВал = ИтогоДопРасходов+Итог("СуммаВАл");
    ЦенаПриходаВал = СуммаПриходаВал/ИтогоНетто;
    Иначе
    ВсегоНетто = Итог("ИтогоНетто"); // нетто всех позиций
    Накопленное = 0;
    Для Сч=1 По КоличествоСтрок()-1 Цикл
    ПолучитьСтрокуПоНомеру(Сч);
    ДопРасходНаКГ = ИтогоДопРасходов/ВсегоНетто;
    СуммаПриходаВал = ДопРасходНаКГ*ИтогоНетто+СуммаВысокий*ОтношениеВалютыКУЕ(Инвойс.ВалютаПоставкиПоИнвойсу)+ТаможОформлВал+ТаможПошлВал+ТаможНДСвал;
    ЦенаПриходаВал = СуммаПриходаВал/ИтогоНетто;
    Накопленное = Накопленное + ДопРасходНаКГ*ИтогоНетто;
    КонецЦикла;
    ПолучитьСтрокуПоНомеру(КоличествоСтрок());
    СуммаПриходаВал = ИтогоДопРасходов-Накопленное+СуммаВысокий*ОтношениеВалютыКУЕ(Инвойс.ВалютаПоставкиПоИнвойсу)+ТаможОформлВал+ТаможПошлВал+ТаможНДСвал;
    ЦенаПриходаВал = СуммаПриходаВал/ИтогоНетто;
    КонецЕсли;
    КонецПроцедуры
    
    
    Вот пример папробуй что отсюда вытянуть . Распределяет доп расходы пропорционально количеству. Ocnfnjr последней строке присваевается весь .

Поделиться этой страницей